Results 1 to 3 of 3

Thread: OnePlus 7 Pro OOS 10 - mass storage not working in USB Arsenal

  1. #1
    Join Date
    2019-Nov
    Posts
    164

    OnePlus 7 Pro OOS 10 - mass storage not working in USB Arsenal

    Hello, so I'm trying to use the USB Mass Storage option in USB Arsenal. I am using the latest OOS available for my phone. I select "Win,Mass Storage" as the only options. I had previously created a 4 GB disc image with dd from the terminal. That image is currently zero-filled. I selected the correct image file in the USB Arsenal, and selected 'mount'. It does say that the correct image is mounted. However, when I connect via USB cable to my PC, device manager states "failure to read device descriptor". I know this is the device that is my phone, because it is the only item that goes away when I unplug the USB A to C cable from my phone, and reappears when I plug it back in.

    Help!! How do I get it to see a USB storage device??

  2. #2
    Join Date
    2019-Nov
    Posts
    164
    Ok, update: The device that was failing to read device descriptor was actually a different device. That device was disconnecting and reconnecting by itself, and it seemed to correlate with my unplugging and replugging my device.

    That said, it is still not showing up under Mass Storage in Windows.

  3. #3
    Join Date
    2019-Nov
    Posts
    164
    More progress:
    It turns out that none of the functions were working. I was most interested in Mass Storage, so that's was I was trying to use. With further testing, I plugged the Phone's USB cable into a port in the back, and, it worked!!

    It would seem, that it works fine on a USB 2.0 port, but not on a USB 3.0 port. I'm going to try again with a Generic USB 3.0 A to USB C cable. There seems to be something funky with the red cable included in the box with the phone. It might just be the cable. It just might...

    To be continued.

Similar Threads

  1. Searchsploit in Nethunter app not working OnePlus 7 Pro
    By zjh24a in forum NetHunter General Questions
    Replies: 4
    Last Post: 2022-01-06, 02:27
  2. Mass storage issue with Drive Droid
    By aaronouthier in forum NetHunter General Questions
    Replies: 3
    Last Post: 2020-04-18, 23:41
  3. Settoolkit Mass Mailer Attack not working.
    By PhydRita in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2020-01-14, 11:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •