Results 1 to 2 of 2

Thread: Kali Linux 2020.2 breaks after doing 'sudo apt-get upgrade'

  1. #1
    Join Date

    Kali Linux 2020.2 breaks after doing 'sudo apt-get upgrade'

    Hello everyone.

    So I've recently started to learn kali and I created a bootable usb. The first thing I've been learning is proxy chains. However, I noticed that I need TOR installed to run the proxy chain and it doesn't seem like TOR comes preinstalled in 2020.2. So I went ahead and tried to install. It wouldn't install from terminal so I had to download it from their website and extract the tar file and then register the app with --register-app.

    Anyway I was still having trouble after installing TOR, the new problem being that when I tried to start TOR with 'service tor start' I get an error saying "bash: service: command not found." I tried it with and without 'sudo.' With 'sudo' I get the error "unit tor.service not found."

    So I did some digging online and the only solution I could find was to run 'sudo apt-get update' and 'sudo apt-get upgrade.' Update worked fine, as it should but initially I kept getting errors during the upgrade that I did not have enough space on the device to install the upgrades (it was a live bootable usb).

    So I reformatted the drive and created a new bootable drive (this time with 10 GB of persistence). At first that seemed to do the trick and the upgrade was getting much further but it takes a long, long time with all the things its downloading and upgrading. By the time it had finished the screen was black with a blinking cursor in the upper left hand corner and the mouse icon occasionally blinking in the center of the screen. Besides that it was completely unresponsive.

    So I tried restarting and booting kali again but now it boots into this broken state.

    When I start up windows with the usb drive plugged in it performs a disk check on the drive. However, under Disk Management it says that the drive is healthy. I've run the upgrade twice now on two different fresh installs.

    And now I'm all out of ideas, please any help is appreciated.

  2. #2
    Join Date
    Hey, I was experiencing these issue aswell and found a valid workaround... maybe it helps you out

Similar Threads

  1. Fresh Kali 2020.1 No GUI, Sudo, or su.
    By redmatter3 in forum Installing Archive
    Replies: 5
    Last Post: 2020-04-15, 03:46
  2. Sudo credentials for Kali Linux 2020.1 Vmware download
    By davinci in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2020-02-10, 17:08
  3. Kali-linux 2018.4a upgrade breaks firefox
    By retired_techie in forum ARM Archive
    Replies: 6
    Last Post: 2018-11-25, 01:31

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts