Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Skype

  1. #11
    Junior Member
    Join Date
    Aug 2013
    Posts
    5
    Thanks for the quick response zimmaro, but unfortunately this doesn't work for me. apt-get install -f, removes skype during operation.

    Here is my output for dpkg -i skype-install.deb:

    Code:
    Code:
    # dpkg -i skype-install.deb 
    Selecting previously unselected package skype.
    (Reading database ... 273098 files and directories currently installed.)
    Unpacking skype (from skype-install.deb) ...
    dpkg: dependency problems prevent configuration of skype:
     skype depends on libasound2 (>= 1.0.16); however:
      Package libasound2:i386 is not installed.
     skype depends on libqt4-dbus (>= 4:4.5.3); however:
      Package libqt4-dbus is not installed.
     skype depends on libqt4-network (>= 4:4.8.0); however:
      Package libqt4-network:i386 is not installed.
     skype depends on libqt4-xml (>= 4:4.5.3); however:
      Package libqt4-xml:i386 is not installed.
     skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
      Package libqtcore4:i386 is not installed.
     skype depends on libqtgui4 (>= 4:4.8.0); however:
      Package libqtgui4:i386 is not installed.
     skype depends on libqtwebkit4 (>= 2.1.0~2011week13); however:
     skype depends on libstdc++6 (>= 4.6); however:
      Package libstdc++6:i386 is not installed.
     skype depends on libxss1; however:
      Package libxss1:i386 is not installed.
     skype depends on libxv1; however:
      Package libxv1:i386 is not installed.
     skype depends on libssl1.0.0; however:
      Package libssl1.0.0:i386 is not instal
    dpkg: error processing skype (--install):
     dependency problems - leaving unconfigured
    Processing triggers for desktop-file-utils ...
    Processing triggers for gnome-menus ...
    Processing triggers for hicolor-icon-theme ...
    Errors were encountered while processing:
     skype
    Here is the output for apt-get install -f # apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages will be REMOVED: skype:i386 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded. 1 not fully installed or removed. After this operation, 39.2 MB disk space will be freed. Do you want to continue [Y/n]? Y (Reading database ... 273246 files and directories currently installed.) Removing skype ... Processing triggers for hicolor-icon-theme ... Processing triggers for desktop-file-utils ... Processing triggers for gnome-menus ...
    Do you have any suggestions?

    Do you have anything special about your sources.list in etc/apt ?

    My sources.list seems very basic. Here it is:

    Code:
    # 
    
    # deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130723-12:53]/ kali contrib main non-free
    
    #deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130723-12:53]/ kali contrib main non-free
    
    ## Security updates
    Thank you for any help that you can provide.

  2. #12
    Senior Member
    Join Date
    Mar 2013
    Location
    milano
    Posts
    187
    Quote Originally Posted by Fatty View Post
    Thanks for the quick response zimmaro, but unfortunately this doesn't work for me. apt-get install -f, removes skype during operation.

    Here is my output for dpkg -i skype-install.deb:

    Code:
    Code:
    # dpkg -i skype-install.deb 
    Selecting previously unselected package skype.
    (Reading database ... 273098 files and directories currently installed.)
    Unpacking skype (from skype-install.deb) ...
    dpkg: dependency problems prevent configuration of skype:
     skype depends on libasound2 (>= 1.0.16); however:
      Package libasound2:i386 is not installed.
     skype depends on libqt4-dbus (>= 4:4.5.3); however:
      Package libqt4-dbus is not installed.
     skype depends on libqt4-network (>= 4:4.8.0); however:
      Package libqt4-network:i386 is not installed.
     skype depends on libqt4-xml (>= 4:4.5.3); however:
      Package libqt4-xml:i386 is not installed.
     skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
      Package libqtcore4:i386 is not installed.
     skype depends on libqtgui4 (>= 4:4.8.0); however:
      Package libqtgui4:i386 is not installed.
     skype depends on libqtwebkit4 (>= 2.1.0~2011week13); however:
     skype depends on libstdc++6 (>= 4.6); however:
      Package libstdc++6:i386 is not installed.
     skype depends on libxss1; however:
      Package libxss1:i386 is not installed.
     skype depends on libxv1; however:
      Package libxv1:i386 is not installed.
     skype depends on libssl1.0.0; however:
      Package libssl1.0.0:i386 is not instal
    dpkg: error processing skype (--install):
     dependency problems - leaving unconfigured
    Processing triggers for desktop-file-utils ...
    Processing triggers for gnome-menus ...
    Processing triggers for hicolor-icon-theme ...
    Errors were encountered while processing:
     skype
    Here is the output for apt-get install -f # apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages will be REMOVED: skype:i386 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded. 1 not fully installed or removed. After this operation, 39.2 MB disk space will be freed. Do you want to continue [Y/n]? Y (Reading database ... 273246 files and directories currently installed.) Removing skype ... Processing triggers for hicolor-icon-theme ... Processing triggers for desktop-file-utils ... Processing triggers for gnome-menus ...
    Do you have any suggestions?

    Do you have anything special about your sources.list in etc/apt ?

    My sources.list seems very basic. Here it is:

    Code:
    # 
    
    # deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130723-12:53]/ kali contrib main non-free
    
    #deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130723-12:53]/ kali contrib main non-free
    
    ## Security updates
    Thank you for any help that you can provide.
    hi
    the problem is your-kali!!
    this is the sources.list default in kali 1.04 64.bit:

    deb http://http.kali.org/kali kali main contrib non-free
    deb-src http://http.kali.org/kali kali main contrib non-free
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    deb-src http://security.kali.org/kali-security kali/updates main contrib non-free


    replace with this update/upgrade your distro , REVOVE TOTALY skype-old /link ..ecc ,clean && repeat ""MY"" procedure to install skype

  3. #13
    Junior Member
    Join Date
    Aug 2013
    Posts
    5
    Thank you for the sources.list file, but unfortunately I am still having a similar problem. When using "apt-get install -f" to fix dependencies the script deletes skype completely.

    Here is the skype removal after "apt-get install -f"
    xtracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 273302 files and directories currently installed.)
    Removing skype ...

    Here is the process for dependency correction:
    Code:
    # apt-get install -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages will be REMOVED:
      skype:i386
    The following NEW packages will be installed:
      libasound2:i386 libaudio2:i386 libavahi-client3:i386
      libavahi-common-data:i386 libavahi-common3:i386 libcomerr2:i386
      libcups2:i386 libexpat1:i386 libffi5:i386 libfontconfig1:i386
      libfreetype6:i386 libgcrypt11:i386 libglib2.0-0:i386 libgnutls26:i386
      libgpg-error0:i386 libgssapi-krb5-2:i386 libjpeg8:i386 libk5crypto3:i386
      libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386
      libmng1:i386 libp11-kit0:i386 libpcre3:i386 libpng12-0:i386 libqt4-dbus:i386
      libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtdbus4:i386
      libqtgui4:i386 libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386
      libtiff4:i386 libxrender1:i386 libxss1:i386 libxt6:i386 libxv1:i386
    0 upgraded, 40 newly installed, 1 to remove and 0 not upgraded.
    1 not fully installed or removed.
    Need to get 17.8 MB of archives.
    After this operation, 11.0 MB of additional disk space will be used.
    Do you want to continue [Y/n]? 
    Get:1 http://security.kali.org/kali-security/ kali/updates/main libgcrypt11 i386 1.5.0-5+deb7u1 [300 kB]
    Get:2 http://http.kali.org/kali/ kali/main libgpg-error0 i386 1.10-3.1 [79.2 kB]
    Get:3 http://http.kali.org/kali/ kali/main libssl1.0.0 i386 1.0.1e-2 [3,029 kB]
    Get:4 http://security.kali.org/kali-security/ kali/updates/main libkrb5support0 i386 1.10.1+dfsg-5+deb7u1 [49.2 kB]
    Get:5 http://http.kali.org/kali/ kali/main libstdc++6 i386 4.7.2-5 [346 kB]    
    Get:6 http://security.kali.org/kali-security/ kali/updates/main libk5crypto3 i386 1.10.1+dfsg-5+deb7u1 [109 kB]
    Get:7 http://http.kali.org/kali/ kali/main libcomerr2 i386 1.42.5-1.1 [56.4 kB]
    Get:8 http://security.kali.org/kali-security/ kali/updates/main libkrb5-3 i386 1.10.1+dfsg-5+deb7u1 [403 kB]
    Get:9 http://http.kali.org/kali/ kali/main libp11-kit0 i386 0.12-3 [51.8 kB]   
    Get:10 http://security.kali.org/kali-security/ kali/updates/main libgssapi-krb5-2 i386 1.10.1+dfsg-5+deb7u1 [149 kB]
    Get:11 http://http.kali.org/kali/ kali/main libtasn1-3 i386 2.13-2 [67.5 kB]   
    Get:12 http://http.kali.org/kali/ kali/main libgnutls26 i386 2.12.20-7 [610 kB]
    Get:13 http://http.kali.org/kali/ kali/main libkeyutils1 i386 1.5.5-3 [8,576 B]
    Get:14 http://http.kali.org/kali/ kali/main libpcre3 i386 1:8.30-5 [240 kB]    
    Get:15 http://http.kali.org/kali/ kali/main libasound2 i386 1.0.25-4 [463 kB]  
    Get:16 http://http.kali.org/kali/ kali/main libxt6 i386 1:1.1.3-1+deb7u1 [206 kB]
    Get:17 http://http.kali.org/kali/ kali/main libaudio2 i386 1.9.3-5 [87.0 kB]   
    Get:18 http://http.kali.org/kali/ kali/main libavahi-common-data i386 0.6.31-2 [132 kB]
    Get:19 http://http.kali.org/kali/ kali/main libavahi-common3 i386 0.6.31-2 [55.1 kB]
    Get:20 http://http.kali.org/kali/ kali/main libavahi-client3 i386 0.6.31-2 [58.7 kB]
    Get:21 http://http.kali.org/kali/ kali/main libcups2 i386 1.5.3-5 [256 kB]     
    Get:22 http://http.kali.org/kali/ kali/main libexpat1 i386 2.1.0-1 [140 kB]    
    Get:23 http://http.kali.org/kali/ kali/main libffi5 i386 3.0.10-3 [21.0 kB]    
    ..... and others no room to post on forum .....
    Fetched 17.8 MB in 1min 12s (245 kB/s)                                         
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 273302 files and directories currently installed.)
    Removing skype ...
    Processing triggers for hicolor-icon-theme ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for gnome-menus ...
    Selecting previously unselected package libgpg-error0:i386.
    (Reading database ... 273154 files and directories currently installed.)
    Unpacking libgpg-error0:i386 (from .../libgpg-error0_1.10-3.1_i386.deb) ...
    Selecting previously unselected package libgcrypt11:i386.
    Unpacking libgcrypt11:i386 (from .../libgcrypt11_1.5.0-5+deb7u1_i386.deb) ...
    Selecting previously unselected package libssl1.0.0:i386.
    Unpacking libssl1.0.0:i386 (from .../libssl1.0.0_1.0.1e-2_i386.deb) ...
    Selecting previously unselected package libstdc++6:i386.
    Unpacking libstdc++6:i386 (from .../libstdc++6_4.7.2-5_i386.deb) ...
    Selecting previously unselected package libcomerr2:i386.
    Unpacking libcomerr2:i386 (from .../libcomerr2_1.42.5-1.1_i386.deb) ...
    Selecting previously unselected package libp11-kit0:i386.
    Unpacking libp11-kit0:i386 (from .../libp11-kit0_0.12-3_i386.deb) ...
    Selecting previously unselected package libtasn1-3:i386.
    Unpacking libtasn1-3:i386 (from .../libtasn1-3_2.13-2_i386.deb) ...
    Selecting previously unselected package libgnutls26:i386.
    Unpacking libgnutls26:i386 (from .../libgnutls26_2.12.20-7_i386.deb) ...
    Selecting previously unselected package libkeyutils1:i386.
    Unpacking libkeyutils1:i386 (from .../libkeyutils1_1.5.5-3_i386.deb) ...
    Selecting previously unselected package libkrb5support0:i386.
    Unpacking libkrb5support0:i386 (from .../libkrb5support0_1.10.1+dfsg-5+deb7u1_i386.deb) ...
    Selecting previously unselected package libk5crypto3:i386.
    Unpacking libk5crypto3:i386 (from .../libk5crypto3_1.10.1+dfsg-5+deb7u1_i386.deb) ...
    Selecting previously unselected package libkrb5-3:i386.
    Unpacking libkrb5-3:i386 (from .../libkrb5-3_1.10.1+dfsg-5+deb7u1_i386.deb) ...
    Selecting previously unselected package libgssapi-krb5-2:i386.
    Unpacking libgssapi-krb5-2:i386 (from .../libgssapi-krb5-2_1.10.1+dfsg-5+deb7u1_i386.deb) ...
    Selecting previously unselected package libpcre3:i386.
    Unpacking libpcre3:i386 (from .../libpcre3_1%3a8.30-5_i386.deb) ...
    Selecting previously unselected package libasound2:i386.
    Unpacking libasound2:i386 (from .../libasound2_1.0.25-4_i386.deb) ...
    Selecting previously unselected package libxt6:i386.
    Unpacking libxt6:i386 (from .../libxt6_1%3a1.1.3-1+deb7u1_i386.deb) ...
    Selecting previously unselected package libaudio2:i386.
    Unpacking libaudio2:i386 (from .../libaudio2_1.9.3-5_i386.deb) ...
    Selecting previously unselected package libavahi-common-data:i386.
    Unpacking libavahi-common-data:i386 (from .../libavahi-common-data_0.6.31-2_i386.deb) ...
    Selecting previously unselected package libavahi-common3:i386.
    Unpacking libavahi-common3:i386 (from .../libavahi-common3_0.6.31-2_i386.deb) ...
    Selecting previously unselected package libavahi-client3:i386.
    Unpacking libavahi-client3:i386 (from .../libavahi-client3_0.6.31-2_i386.deb) ...
    Selecting previously unselected package libcups2:i386.
    Unpacking libcups2:i386 (from .../libcups2_1.5.3-5_i386.deb) ...
    Selecting previously unselected package libexpat1:i386.
    Unpacking libexpat1:i386 (from .../libexpat1_2.1.0-1_i386.deb) ...
    Selecting previously unselected package libffi5:i386.
    Unpacking libffi5:i386 (from .../libffi5_3.0.10-3_i386.deb) ...
    Selecting previously unselected package libfreetype6:i386.
    Unpacking libfreetype6:i386 (from .../libfreetype6_2.4.9-1.1_i386.deb) ...
    Selecting previously unselected package libfontconfig1:i386.
    Unpacking libfontconfig1:i386 (from .../libfontconfig1_2.9.0-7.1_i386.deb) ...
    Selecting previously unselected package libglib2.0-0:i386.
    Unpacking libglib2.0-0:i386 (from .../libglib2.0-0_2.33.12+really2.32.4-5_i386.deb) ...
    Selecting previously unselected package libjpeg8:i386.
    Unpacking libjpeg8:i386 (from .../libjpeg8_8d-1_i386.deb) ...
    Selecting previously unselected package liblcms1:i386.
    Unpacking liblcms1:i386 (from .../liblcms1_1.19.dfsg-1.2_i386.deb) ...
    Selecting previously unselected package libmng1:i386.
    Unpacking libmng1:i386 (from .../libmng1_1.0.10-3_i386.deb) ...
    Selecting previously unselected package libpng12-0:i386.
    Unpacking libpng12-0:i386 (from .../libpng12-0_1.2.49-1_i386.deb) ...
    Selecting previously unselected package libqtcore4:i386.
    Unpacking libqtcore4:i386 (from .../libqtcore4_4%3a4.8.2+dfsg-11_i386.deb) ...
    Selecting previously unselected package libqt4-xml:i386.
    Unpacking libqt4-xml:i386 (from .../libqt4-xml_4%3a4.8.2+dfsg-11_i386.deb) ...
    Selecting previously unselected package libqtdbus4:i386.
    Unpacking libqtdbus4:i386 (from .../libqtdbus4_4%3a4.8.2+dfsg-11_i386.deb) ...
    Selecting previously unselected package libqt4-network:i386.
    Unpacking libqt4-network:i386 (from .../libqt4-network_4%3a4.8.2+dfsg-11_i386.deb) ...
    Selecting previously unselected package libtiff4:i386.
    Unpacking libtiff4:i386 (from .../libtiff4_3.9.6-11_i386.deb) ...
    Selecting previously unselected package libxrender1:i386.
    Unpacking libxrender1:i386 (from .../libxrender1_1%3a0.9.7-1+deb7u1_i386.deb) ...
    Selecting previously unselected package libqtgui4:i386.
    Unpacking libqtgui4:i386 (from .../libqtgui4_4%3a4.8.2+dfsg-11_i386.deb) ...
    Selecting previously unselected package libxss1:i386.
    Unpacking libxss1:i386 (from .../libxss1_1%3a1.2.2-1_i386.deb) ...
    Selecting previously unselected package libxv1:i386.
    Unpacking libxv1:i386 (from .../libxv1_2%3a1.0.7-1+deb7u1_i386.deb) ...
    Selecting previously unselected package libqt4-dbus:i386.
    Unpacking libqt4-dbus:i386 (from .../libqt4-dbus_4%3a4.8.2+dfsg-11_i386.deb) ...
    Processing triggers for man-db ...
    Processing triggers for libglib2.0-0:amd64 ...
    Setting up libgpg-error0:i386 (1.10-3.1) ...
    Setting up libgcrypt11:i386 (1.5.0-5+deb7u1) ...
    Setting up ............
    Not enough room to show the rest of the code, but essentially it is all setting up ....

    Please let me know if you have any suggestions. Thank you.

  4. #14
    Junior Member
    Join Date
    Sep 2013
    Posts
    1
    Quote Originally Posted by zimmaro View Post
    hi
    i'm testing NOW on kali64 1.0.4 (live-mode-VM) && WORKED !!!!

    dpkg --add-architecture i386
    apt-get update
    apt-get install libpulse0:i386
    wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
    dpkg -i skype-install.deb
    apt-get install -f


    NB: apt-get install -f correct ""dipendence-problems""

    http://imageshack.us/f/809/ycn.png/
    bye
    Out of all the crap I tried... this is the only thing that worked...

    Thanks Brother...

    Cheers,
    DZ

  5. #15
    Junior Member
    Join Date
    Apr 2013
    Posts
    10
    This wordek for me on AMD64. Running skype fine now.

    Log in as root:
    $ su -l
    If you disabled root login during the installation process, you may run $ sudo bash OR insert sudo in front of the following commands.

    Now add the new architecture i386:
    # dpkg --add-architecture i386
    # aptitude clean && aptitude update

    Install libpulse:
    # aptitude install libpulse0 libpulse0:i386

    Then, download Skype:
    # wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb

    WARNING: Fork: Here this manual way diverges from presented one at Debian Wiki!

    Install Skype dependencies:
    # dpkg-deb --field skype-install.deb Depends
    # aptitude install <every package from the dpkg-deb output, adding :i386 suffix>

    Closing the finish line, install Skype itself:
    # dpkg --install skype-install.deb

    The last thing to do is to enable "[x] Check for update on startup" in the ‘Advanced’ tab of the options menu in Skype. In this case Skype will notify you about new versions.

    That's all! Enjoy!

  6. #16
    Junior Member
    Join Date
    Sep 2013
    Location
    Alaska
    Posts
    1
    well, the same problem !

  7. #17
    Junior Member
    Join Date
    Jan 2014
    Posts
    1
    I also seem to have the same problem, I've tried every method of installing Skype mentiened in this thread and not a single one worked, for some reason trying to manually install the dependencies won't work. Anybody have any idea's?

  8. #18
    Junior Member
    Join Date
    Feb 2014
    Posts
    1
    hi all,.
    first of all i must to say that i'm new onthis forum so please don't be rude with me for be a newbie.
    recentl i installed kali lnux 1.0.6 cause i'm studying informatic engineering on Spain and i want to specialize on security and all of that stuff (actually i'm just starting with the theory).
    my problem is that i'm trying to install skype and no one of the solutions that you guys gave in this post actually helps me.
    here's the log as root (sorry, in spanish but i think you can udnerstand):
    dpkg -i skype-ubuntu-lucid_4.1.0.20-1_i386.deb
    (Leyendo la base de datos ... 322083 ficheros o directorios instalados actualmente.)
    Preparando para reemplazar skype 4.1.0.20-1 (usando skype-ubuntu-lucid_4.1.0.20-1_i386.deb) ...
    Desempaquetando el reemplazo de skype ...
    dpkg: problemas de dependencias impiden la configuración de skype:
    skype depende de libasound2 (>> 1.0.22).
    skype depende de libc6 (>= 2.3.6-6~).
    skype depende de libc6 (>= 2.7).
    skype depende de libgcc1 (>= 1:4.1.1).
    skype depende de libqt4-dbus (>= 4:4.5.3).
    skype depende de libqt4-network (>= 4:4.5.3).
    skype depende de libqt4-webkit (>= 4:4.5.3).
    skype depende de libqt4-xml (>= 4:4.5.3).
    skype depende de libqtcore4 (>= 4:4.6.1).
    skype depende de libqtgui4 (>= 4:4.6.1).
    skype depende de libstdc++6 (>= 4.4.0).
    skype depende de libx11-6 (>= 0).
    skype depende de libxext6 (>= 0).
    skype depende de libxss1.
    skype depende de libxv1.

    dpkg: error al procesar skype (--install):
    problemas de dependencias - se deja sin configurar
    Procesando disparadores para desktop-file-utils ...
    Procesando disparadores para gnome-menus ...
    Se encontraron errores al procesar:
    skype
    also i tried to install all the dependencies but even trying to installing one by one...:
    apt-get install libgcc1: i386
    Reading package lists ... done
    Building dependency tree
    Reading state information ... done
    The package libgcc1: i386 is not available but referred to by another package
    him. This may mean that the package is missing, has been obsoleted, or is only
    available from another source
    can anybody help me please?.
    anyway thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •