Results 1 to 2 of 2

Thread: E: Package 'libpng12-0' has no installation candidate

  1. #1
    Join Date
    2020-Aug
    Posts
    1

    E: Package 'libpng12-0' has no installation candidate

    Error on my Raspberry Pi 3 Model B while installing the package.

    I'm using command line -
    sudo apt-get install libjpeg-dev libtiff5-dev libjasper-dev libpng12-dev

    The return error is
    root@kali:~# sudo apt-get install libjpeg-dev libtiff5-dev libjasper-dev libpng12-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libpng12-dev is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Unable to locate package libjasper-dev
    E: Package 'libpng12-dev' has no installation candidate

    And when I'm trying to install libpng12-dev by following command
    sudo apt-get install libpng12-0

    I'm getting an error again
    root@kali:~# sudo apt-get install libpng12-0

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libpng12-0 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'libpng12-0' has no installation candidate

    So, please help me out. If I install it manually please provide a link and also the path of root directory where I can extract these files manually.
    I'm using this package for my Object Detection Project with Pi camera. I'll be grateful if anyone can help me out about this. Thanks

  2. #2
    Join Date
    2014-Feb
    Posts
    299
    libpng12 went away a long time ago. the current libpng package is libpng16-16 - you can search in the future using something like "apt search libpng" and finding the libpng package in the output, or narrow it down to only packages that start with libpng via something like "apt search ^libpng"

Similar Threads

  1. E: Package 'libjpeg62' has no installation candidate
    By deadbol in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-12-28, 17:35

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •