Results 1 to 3 of 3

Thread: Enabling Bluetooth During Boot

  1. #1
    Join Date
    2020-Aug
    Posts
    2

    Enabling Bluetooth During Boot

    Building a mobile RPi 4 Kali box with an iclever foldable bluetooth keyboard. While I've figured out how to enable bluetooth with "systemctl start bluetooth.service" that doesn't help on startup!

    Have validated "AutoEnable=true" in /etc/bluetooth/main.conf per https://github.com/blueman-project/b...roubleshooting but it still doesn't start on reboot.

    Also tried the deprecated method of creating a "bluetooth-keyboard-auto-enable.rules" file in /etc/udev/rules.d (also didn't work) containing the following:
    ACTION=="add",
    SUBSYSTEM=="bluetooth",
    KERNEL=="hci[0-9]*",
    RUN+="/bin/hciconfig %k up"Hoping it's a variable I'm missing or something else obvious. Any help/feedback is welcome.

    Thanks!

  2. #2
    Join Date
    2014-Feb
    Posts
    299
    You likely need to also enable the "hciuart" service - so, `systemctl enable --now hciuart && systemctl restart bluetooth` - this will enable (and start) the hciuart service, and then restart bluetooth.

  3. #3
    Join Date
    2020-Aug
    Posts
    2
    Was able to solve this by modifying the 'crontab' file. Simple '@reboot' with 'root' user privileges running 'systemctl start bluetooth.service' allowed the keyboard to work at startup.

    Will be keeping crontab in mind for other services desired at startup.

Similar Threads

  1. No Bluetooth found Plug in a dongle to use Bluetooth - kali linux
    By edoconan in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-03-29, 18:14
  2. No Bluetooth found Plug in a dongle to use Bluetooth - kali linux
    By edoconan in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-03-29, 00:43
  3. Replies: 1
    Last Post: 2018-09-25, 20:34
  4. Replies: 8
    Last Post: 2017-05-25, 05:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •