Results 1 to 3 of 3

Thread: UART on PI4

  1. #1

    UART on PI4

    Hi,

    I have been trying for a few days now to enable UART to control a PI hat.
    So far i have done the following

    posted enable_uart=1 to /boot/config.txt
    changed /boot/cmdline to:
    dwc_otg.fiq_fix_enable=2 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext3 rootwait rootflags=noload net.ifnames=0

    Stopped serial-getty
    systemctl stop serial-getty@ttyAMA0.service
    systemctl disable serial-getty@ttyAMA0.service

    However i cannot use minicom to get any data from UART.

    I must be doing something wrong. Did anybody get UART to work on the Pi 4 and if yes how?
    Logging:
    Dmesg: UART
    [ 0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 cma=64M bcm2708_fb.fbwidth=0 bcm2708_fb.fbheight=0 bcm2708_fb.fbswap=1 smsc95xx.macaddr=DC:A6:32:BE:36:58 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 dwc_otg.fiq_fix_enable=2 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext3 rootwait rootflags=noload net.ifnames=0
    [ 0.396348] uart-pl011 fe201000.serial: cts_event_workaround enabled
    [ 6.190953] uart-pl011 fe201000.serial: no DMA platform data

    Dmesg:tty
    [ 0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 cma=64M bcm2708_fb.fbwidth=0 bcm2708_fb.fbheight=0 bcm2708_fb.fbswap=1 smsc95xx.macaddr=DC:A6:32:BE:36:58 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 dwc_otg.fiq_fix_enable=2 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext3 rootwait rootflags=noload net.ifnames=0
    [ 0.000698] console [tty1] enabled
    [ 0.396395] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 34, base_baud = 0) is a PL011 rev2
    [ 0.400313] fe215040.serial: ttyS0 at MMIO 0x0 (irq = 36, base_baud = 62500000) is a 16550
    [ 4.718960] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB0
    [ 4.723560] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB1
    [ 4.737215] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB2
    [ 4.738092] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB3
    [ 4.738819] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB4

    Setserial output
    /dev/ttyAMA0, UART: undefined, Port: 0x0000, IRQ: 34
    /dev/ttyS0, UART: 16550, Port: 0x0000, IRQ: 36



    P.S.
    Appologies if this is supposed to go into the ARM thread. Please let me know.

  2. #2
    Join Date
    2014-Feb
    Posts
    299
    You also need to add `console=ttyAMA0` to the cmdline.txt file if you want output on there. Unless I'm misunderstanding what you're asking.

  3. #3
    Hi Steev,

    Thanks for the reply. i managed to fix it by installing a non-defective pi-hat.
    It is working non, For reason console=ttyAMA0 is not required for it to work.

    Thanks.

Similar Threads

  1. ALFA AWUS036NHA hacking EEPROM via UART/JTAG
    By mokba in forum TroubleShooting Archive
    Replies: 79
    Last Post: 2017-05-28, 17:07
  2. ALFA AWUS036NHA hacking EEPROM via UART/JTAG
    By mokba in forum TroubleShooting Archive
    Replies: 79
    Last Post: 2017-05-28, 17:07

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •