Results 1 to 10 of 10

Thread: Nexus 6P monitor mode installation issue

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2020-Aug
    Posts
    9

    Post Nexus 6P monitor mode installation issue

    Hello all

    I am struggling to get monitor mode to work on the nexus 6P. The other day I installed nethunter on a Nexus 6P 32GB using TWRP recovery and Magisk root. I then flashed nethunter. When attempting to use nexmon to try and install the wifi firmware, the app homepage would repeatedly crash, and after supposedly installing the firmware (radio chip bcm4358, version 7.112.300.14), monitor mode wouldn't work. I also tried a fresh nethunter installation, and tried building it from source here but this didn't work either. Has anyone got a fix or solution?

    Thanks in advance

  2. #2
    Join Date
    2019-Nov
    Posts
    149
    I suspect you are trying this under LineageOS 17.1 which uses Android 10. AFAIK, Nexmon is not compatible with Android 10. I have a 64 GB model, and monitor mode works fine without needing Nexmon. Open the main NetHunter app, and go to Custom Commands section. Find the item titled “Start Wlan0 monitor mode”, and the Run button to the right of it.

    Boom, your internal WiFi is now in monitor mode. To exit monitor mode, tap run next to “Stop Wlan0 monitor mode”.

  3. #3
    Join Date
    2020-Aug
    Posts
    9
    Quote Originally Posted by aaronouthier View Post
    I suspect you are trying this under LineageOS 17.1 which uses Android 10. AFAIK, Nexmon is not compatible with Android 10. I have a 64 GB model, and monitor mode works fine without needing Nexmon. Open the main NetHunter app, and go to Custom Commands section. Find the item titled “Start Wlan0 monitor mode”, and the Run button to the right of it.

    Boom, your internal WiFi is now in monitor mode. To exit monitor mode, tap run next to “Stop Wlan0 monitor mode”.
    I installed the nexus 6p oreo image, which is android 8.1. I am not using lineage os.

  4. #4
    Join Date
    2019-Nov
    Posts
    149
    Okay, well I haven’t tried it in Oreo, but it might still work. Worst case scenario, you’ll get an error message.

  5. #5
    Join Date
    2020-Aug
    Posts
    9
    Quote Originally Posted by aaronouthier View Post
    you’ll get an error message.
    This is precisely the problem. I'm not sure whats going on, and i might try reinstall and then immediatley build firmware for my phone's radio chip.

  6. #6
    Join Date
    2019-Nov
    Posts
    149
    Did you try the method I mentioned? It turns out that Nexmon doesn’t work with Android 8 and up.
    If it still doesn’t work as expected, I can link the instructions for installing LineageOS. Monitor mode works fine there (using the method in post #2).

  7. #7
    Join Date
    2020-Aug
    Posts
    9
    Quote Originally Posted by aaronouthier View Post
    Did you try the method I mentioned? It turns out that Nexmon doesn’t work with Android 8 and up.
    If it still doesn’t work as expected, I can link the instructions for installing LineageOS. Monitor mode works fine there (using the method in post #2).
    There's a second download image for nethunter called "los ten"Screenshot_2020-09-04 Kali Linux NetHunter Downloads Offensive Security.png which I might try. Not sure what it is, but the name suggests it is lineage os.

  8. #8
    Join Date
    2019-Nov
    Posts
    149
    It is NetHunter for LineageOS. You need to install LineageOS first. There is an unofficial version on xda-developers.com.
    https://forum.xda-developers.com/nex...ngler-t4012099

  9. #9
    Join Date
    2020-Aug
    Posts
    9
    Ok thank you!

  10. #10
    Join Date
    2020-Sep
    Posts
    3
    Monitor mode does work in 8.1. The nethunter rom already has the nexmon tools installed, no need to build them.

    The trick is that you need to swap out the firmware, which isn't really well-publicized.

    You can find the monitor-enabled firmware here: https://gitlab.com/kalilinux/nethunt...gler/nexmon-fw

    To install it, you need to be in the ANDROID shell (not the kali chroot shell).
    This is how I did it.

    1) First, download the monitor-enabled firmware from the above link -- get the one labelled "fw_bcmdhd.bin.nexmon".
    2) From a PC with adb installed, push that firmware file onto the device:
    adb push fw_bcmdhd.bin.nexmon /mnt/sdcard/
    3) now get a shell on the device:
    adb shell
    4) now that you're on the device, you need to become root:
    su
    5) we need to replace the firmware, which is on the read-only /vendor partition. so we need to make it read-writable.
    mount -o rw,remount /vendor

    6) go to the firmware directory
    cd /vendor/firmware
    7) copy the modified monitor-mode firmware over top of the original
    cp /mnt/sdcard/fw_bcmdhd.bin.nexmon fw_bcmdhd.bin

    Now reboot the phone and monitor mode should work.

Similar Threads

  1. Nexus 5 - Can't put wlan0 in monitor mode - Nexmon crashing
    By pispuso in forum NetHunter General Questions
    Replies: 4
    Last Post: 2021-01-07, 16:39
  2. Nexus 5 - Can't get monitor mode to work
    By pispuso in forum NetHunter General Questions
    Replies: 7
    Last Post: 2020-10-24, 00:09
  3. Nexus 5 monitor mode without usb wifi card
    By Anarkad in forum NetHunter General Questions
    Replies: 3
    Last Post: 2016-09-03, 01:53
  4. Monitor mode, error getting flags - Nexus 4
    By 09stephenb in forum NetHunter General Questions
    Replies: 1
    Last Post: 2015-08-30, 22:09
  5. Monitor mode, error getting flags - Nexus 4
    By 09stephenb in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-08-15, 12:32

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •