I just installed Kali Linux VirtualBox 64 bit, and tried to perform 'sudo apt update'. And the error I received is:

E: Failed to fetch https://ftp.acc.umu.se/mirror/kali.o...64/Packages.gz Hash Sum mismatch
Hashes of expected file:
- Filesize:16551205 [weak]
- SHA256:fc4315861c77135e716ba7723942726d7d1dca6bd04 ea02f841ae04774eae9fa
- SHA1:5de8e5576c8596fc58dabc41fe05b4cd736b28eb [weak]
- MD5Sum:a4998312ee36cbe01eb13afe9251768a [weak]
Hashes of received file:
- SHA256:49161b98c671853371d55d5944110e88aab03950241 e3f1535f8e5735aae2fac
- SHA1:81712535553eba7361674dbdd652d0a9f90ab0b5 [weak]
- MD5Sum:2351a1e01872582ab9f0c7b76dd92e0d [weak]
- Filesize:16551205 [weak]
E: Some index files failed to download. They have been ignored, or old ones used instead.

On my `/etc/apt/sources.list` the mirror I have is: http://http.kali.org/kali
So, why is the download even occuring from the mirror 'https://ftp.acc.umu.se/mirror/kali.org/kali'?
Is there any other place where I can replace this mirror with something that works?
Or is there some other solution to this problem?

And I have tried other solutions such as performing 'apt clean' or entering 'rm -rf /var/lib/apt/lists/*' and none of them work.