Results 1 to 7 of 7

Thread: wlan1 not switching to wlan1mon when in monitor mode

  1. #1
    Join Date
    2020-Sep
    Posts
    3

    wlan1 not switching to wlan1mon when in monitor mode

    Hello..
    I have a problem when puting my wireless card to monitor mode.
    laptop has pci wlan0 which is with firmware iwlwifi.
    When airmon-ng start wlan0 card is switching to wlan0mon (mac80211 station mode vif enabled on [phy0]wlan0)

    and everything is fine.
    When using usb device alfa alfa awus036h with rtl8187 chipset
    and airmon-ng start wlan1 device just staying wlan1 monitor mode and missing (mac80211 station mode vif enabled on [phy1]wlan1) and iwconfig
    shows that is in monitor mode.
    This makes problems with reaver etc.
    Before updating everything was working fine
    Any help would be appreciated.

  2. #2
    Join Date
    2015-Mar
    Posts
    48
    I have the same problem. It was working with the older kernel up to 5.7, so it might not be just kali but also other distros of linux.

  3. #3
    Join Date
    2020-Nov
    Location
    Serangoon
    Posts
    2
    Nice keep it up....

  4. #4
    Join Date
    2020-Nov
    Location
    Serangoon
    Posts
    2
    Quote Originally Posted by scorpius View Post
    I have the same problem. It was working with the older kernel up to 5.7, so it might not be just kali but also other distros of linux.
    haaahaaaaa,,,,,,,,,

  5. #5
    Join Date
    2020-Nov
    Location
    Missouri
    Posts
    1
    Try adding the networking to network manager under /etc/NetworkManger or simpliy just try restart your network by : service network-manager restart
    if all else fails:
    Try
    airmon-ng stop wlan0mon
    then restart network manager
    service network-manager restart
    <-This seems to be the most common fix!^
    or
    ifconfig wlan0 down
    iwconfig wlan0 mode managed
    ifconfig wlan0 up
    or
    ifconfig wlan0 down
    iwconfig wlan0 mode monitor
    ifconfig wlan0 up

  6. #6
    Join Date
    2013-Jul
    Posts
    841
    Musket Teams noted this a while back. The device is placed in monitor mode it just uses the same wlan1 designation. Put the device in monitor mode and then type airmon-ng start wlan1 a second time or take the device out of monitor mode and see the response from airmon-ng.

    MTeam have been running reaver thru a terminal window with this version with no problems. It you are running a script the script will have to be patched to take both wlan1mon and wlan1 designations. Out latest handshakeharvest has this patch and we will get around to patching other scripts soon .

    You could also use iw and manually put the device in monitor mode. Or get an older version of airmon-ng.sh place it in root and run the older version from root ./airmon-ng.sh.

    You could post a question in the aircrack-ng forums if you want more info.

    Go here and read thru the comments

    https://forums.kali.org/showthread.p...rmon-ng-output


    MTeams

  7. #7
    Quote Originally Posted by darkshadowman8 View Post
    Hello..
    I have a problem when puting my wireless card to monitor mode.
    laptop has pci wlan0 which is with firmware iwlwifi.
    When airmon-ng start wlan0 card is switching to wlan0mon (mac80211 station mode vif enabled on [phy0]wlan0)

    and everything is fine.
    When using usb device alfa alfa awus036h with rtl8187 chipset
    and airmon-ng start wlan1 device just staying wlan1 monitor mode and missing (mac80211 station mode vif enabled on [phy1]wlan1) and iwconfig
    shows that is in monitor mode.
    This makes problems with reaver etc.
    Before updating everything was working fine
    Any help would be appreciated.
    https://github.com/nu11secur1ty/w1f1.../master/airmon

Similar Threads

  1. wlan1 not switching to wlan1mon when in monitor mode
    By darkshadowman8 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-09-27, 14:55
  2. problem with monitor mode - not switching to wlan1mon
    By darkshadowman8 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-09-19, 11:28
  3. Monitor mode airodump-ng wlan1 is soft blocked
    By win32gui in forum General Archive
    Replies: 0
    Last Post: 2019-12-15, 11:09
  4. Replies: 5
    Last Post: 2015-09-29, 07:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •