Hello Kali Linux Community
Ive been trying to install hcxtool but I cant do it.
I tried many times updating and upgrading and every things in fine.
I did git clone https://github.com/ZerBea/hcxtools and I had some error messages
and after all I delete the Directory that was created when I ran the comand git hub with
sudo rm -rf hcxtools and try to install again but this time I got another kind of trouble.
Every time I delete and try to install hxctool Ive ran comands like sudo apt-get autoclean
and autoremove.
And now here its the trouble:

noelc@NoelCruz-L:~$ ls
besside.log Desktop Documents Downloads hcxdumptool hcxtools Music Pictures Public Templates Videos wep.cap wpa.cap
noelc@NoelCruz-L:~$ cd hcxtools
noelc@NoelCruz-L:~/hcxtools$ make
make: Nothing to be done for 'all'.

noelc@NoelCruz-L:~/hcxtools$ sudo make install
install -D -m 0644 manpages/hcxpcapngtool.1 /usr/local/share/man/man1/hcxpcapngtool.1
install -D -m 0755 hcxpcapngtool /usr/local/bin/hcxpcapngtool
install -D -m 0644 manpages/hcxhashtool.1 /usr/local/share/man/man1/hcxhashtool.1
install -D -m 0755 hcxhashtool /usr/local/bin/hcxhashtool
install -D -m 0644 manpages/hcxpsktool.1 /usr/local/share/man/man1/hcxpsktool.1
install -D -m 0755 hcxpsktool /usr/local/bin/hcxpsktool
install -D -m 0755 hcxwltool /usr/local/bin/hcxwltool
install -D -m 0644 manpages/hcxhash2cap.1 /usr/local/share/man/man1/hcxhash2cap.1
install -D -m 0755 hcxhash2cap /usr/local/bin/hcxhash2cap
install -D -m 0644 manpages/wlancap2wpasec.1 /usr/local/share/man/man1/wlancap2wpasec.1
install -D -m 0755 wlancap2wpasec /usr/local/bin/wlancap2wpasec
install -D -m 0755 whoismac /usr/local/bin/whoismac
install -D -m 0755 hcxpmkidtool /usr/local/bin/hcxpmkidtool
install -D -m 0755 hcxhashcattool /usr/local/bin/hcxhashcattool
install -D -m 0755 hcxmactool /usr/local/bin/hcxmactool
install -D -m 0755 hcxessidtool /usr/local/bin/hcxessidtool
install -D -m 0755 wlanpmk2hcx /usr/local/bin/wlanpmk2hcx

So community I will appreciate your help and one day help others.
Ive tried around 10 day looking for an answer.