Results 1 to 14 of 14

Thread: Various WSL2 issues.

  1. #1
    Join Date
    2019-Nov
    Posts
    149

    Various WSL2 issues.

    Hello!
    I've been using Kali and NetHunter for a while. When I heard about WSL and Kali?s support for it, I wanted to try it. However, I can't seem to get kex working. When I run any of "kex" or "kex --win" or "kex -sl -s", I just get a completely black desktop, with a dialog box containing the message: "Unable to contact settings server. Failed to execute child process dbus-launch (no such file or directory)".

    I did click allow at the firewall prompt for PulseAudio.exe, as instructed. I believe I have followed all instructions to the letter. All updates are applied via "sudo apt-get update && sudo apt-get full-upgrade -y". I have verified that I am running WSL2 and not the original WSL.

    Anti-virus is excluding all Kali data. It originally had quarantined like 750 files, so I completely uninstalled Kali, and added the exclusion for the entire WSL working folder, then reinstalled Kali. I gleaned the WSL working directory from the Anti-Virus logs.

  2. #2
    I have the same issue, please someone can help?

    Best regards!

  3. #3
    Join Date
    2020-Nov
    Posts
    1
    Quote Originally Posted by aaronouthier View Post
    Hello!
    I've been using Kali and NetHunter for a while. When I heard about WSL and Kali?s support for it, I wanted to try it. However, I can't seem to get kex working. When I run any of "kex" or "kex --win" or "kex -sl -s", I just get a completely black desktop, with a dialog box containing the message: "Unable to contact settings server. Failed to execute child process dbus-launch (no such file or directory)".

    I did click allow at the firewall prompt for PulseAudio.exe, as instructed. I believe I have followed all instructions to the letter. All updates are applied via "sudo apt-get update && sudo apt-get full-upgrade -y". I have verified that I am running WSL2 and not the original WSL.

    Anti-virus is excluding all Kali data. It originally had quarantined like 750 files, so I completely uninstalled Kali, and added the exclusion for the entire WSL working folder, then reinstalled Kali. I gleaned the WSL working directory from the Anti-Virus logs.
    Same issue here, I added all exceptions in firewall and get this error.
    Screenshot https://pasteboard.co/JAPOgMY.png

  4. #4
    Join Date
    2020-Nov
    Posts
    2
    I am having this exact issue at the moment and I am trying to find an answer somewhere.

    kex.jpg

  5. #5
    Join Date
    2020-Nov
    Posts
    2
    I found the answer.

    https://www.daniel-pinto.dev/wsl2-ka...-launch-issue/

    install dbus-X11 ( sudo apt-get install -y dbus-x11 )

    works now!

  6. #6
    Join Date
    2020-Nov
    Posts
    1
    i have this problem, too.
    run "sudo apt-get install dbus-x11", and it works.

  7. #7
    Join Date
    2020-Nov
    Posts
    1
    Same problem here solved by "sudo apt-get install dbus-x11" , then cd into your "/home/USERNAME" folder, not the /c/mnt windows mount. kill kex with "kex --stop" and start again with "kex".
    And I had trouble exiting the full-screen error message / black screen - you can open the tigerVNC menu with (fn) + F8 if needed and exit fullscreen there



  8. #8
    Join Date
    2020-Nov
    Posts
    1
    Hi i had the same problem try: sudo apt-get install dbus-x11 it solved that one for me

  9. #9
    Join Date
    2020-Nov
    Posts
    1
    Hello. Same issue

  10. #10
    Join Date
    2020-Nov
    Posts
    1
    just run this cmdsudo apt install dbus-x11

  11. #11
    Join Date
    2020-Nov
    Posts
    1
    Hy, I have the same problem. Since one year no answer?

  12. #12
    Join Date
    2020-Nov
    Location
    Close orbit around Boston
    Posts
    2
    I don't even get the dialog box; I just get the black desktop (well, black fullscreen window, apparently; I was able to move it to see the Windows screen behind it) and an invitation to press F8 for the menu.

    My best guess is that I botched the firewall approval and kex isn't successfully scraping the Windows screen. Looked at the firewall config but didn't see anything obviously related to the Kali or kex setups. If anyone can point me at what to check, I'd appreciate it.

    (Probably unrelated: The how-to page shows the command as "win-kex". Since that doesn't seem to exist, I've been assuming that was a typo and just issuing the command as "kex". Or was there something else I needed to install?)

  13. #13
    Join Date
    2021-Jan
    Location
    Brisbane, QLD Australia
    Posts
    2
    I banged my head against the same wall ...

    '# apt install dbus-x11'

    fixed the issue for me

  14. #14
    I am facing same thing, but I have reinstalled kali linux WSL, after uninstalling it once. Before uninstalling it was working fine.

Similar Threads

  1. Win-Kex in WSL2 Kali fails to connect after system reboot.
    By snowmirage in forum TroubleShooting Archive
    Replies: 9
    Last Post: 2021-03-12, 10:35
  2. Windows 10 - WSL2 - kex
    By AzO666 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-11-11, 21:39
  3. Kali WSL2 / KEX change from XFCE to KDE
    By AGZ in forum General Archive
    Replies: 1
    Last Post: 2020-09-17, 08:45
  4. Problem running Kex on wsl2
    By mwoodpatrick in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-09-15, 13:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •