In short - the problem is - kali is latest version, updated, upgraded, last driver for awus1900 is installed but no wireless wireless extensions.

I tried a lot of things, different tutorials on how to install the driver for awus1900 on kali, but can't get the final result.

What I tried:
  • to switch between USB2.0 to USB3.0 and vice versa
  • to test with different drivers on the host system, from win7 to win10 (in VM the situation is the same, in the host this adapter works fine)
  • update, upgrade kali
  • install latest driver for awus (using apt and manual make,install) - no changes

some info:
VMware 15
kali@testvm:~uname -a
Linux testvm 5.9.0-kali1-amd64 #1 SMP Debian 5.9.1-1kali2 (2020-10-29) x86_64 GNU/Linux

kali@testvm:~ sudo apt install realtek-rtl88xxau-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
realtek-rtl88xxau-dkms is already the newest version (
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

the problem is here:
kali@testvm:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Why wlan0 is missing?

But here the adapter is detected OK:
kali@testvm:~$ sudo lsusb
Bus 001 Device 002: ID 0bda:8813 Realtek Semiconductor Corp. RTL8814AU 802.11a/b/g/n/ac Wireless Adapter

dmesg output:
[ 753.502696] usb 1-1: new high-speed USB device number 2 using ehci-pci
[ 753.872460] usb 1-1: New USB device found, idVendor=0bda, idProduct=8813, bcdDevice= 0.00
[ 753.872463] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 753.872465] usb 1-1: Product: 802.11ac NIC
[ 753.872466] usb 1-1: Manufacturer: Realtek
[ 753.872468] usb 1-1: SerialNumber: 123456

I have no more ideas what to do . Please, help. And yes, I can't test with kali on real machine, only in virtual.