Results 1 to 5 of 5

Thread: MITMf installing&configuring troubles

  1. #1
    Join Date
    2019-Aug
    Posts
    4

    MITMf installing&configuring troubles

    Hello everyone!
    I've tried to install and configure MITMf in lots of different ways on my 2020.4 Kali but unfortunately I failed.
    Are there any ways to fix this problem, because I always end up with:

    ┌──(root��kali)-[/home/kali/MITMf]
    └─# python ./mitmf.py 1 ⨯
    Traceback (most recent call last):
    File "./mitmf.py", line 29, in <module>
    import core.responder.settings as settings
    File "/home/kali/MITMf/core/responder/settings.py", line 24, in <module>
    from core.configwatcher import ConfigWatcher
    File "/home/kali/MITMf/core/configwatcher.py", line 20, in <module>
    import pyinotify
    ImportError: No module named pyinotify

    Thank in advance

  2. #2
    Join Date
    2020-Dec
    Posts
    1
    hi guys i had exactly same problem so did u find any solution yet

  3. #3
    Join Date
    2019-Mar
    Location
    Western Canada
    Posts
    11
    Hi Burden,
    This is not super helpful in all likelihood, but just wanted to let you know that I ran into the same trouble using mitmf over the last couple of years. I was able to fix some of the issues up until about this time last year by manually installing the required python modules (script included below), but starting last year I found that it was getting too difficult and the mitmf repo said it was old/unsupported. I moved to bettercap which was newer and better supported. Too bad as mitmf was a really interesting demo tool back in the day.

    My old script to 'fix' mitmf is below. It only worked back in the Kali 2018.3 era not newer versions, but if you really want to try getting it to work, you could probably use something _like_ this to try. Good luck.

    # This script automates the process of installing mitmf and mimtf lib and then
    # automatically fixing an issue with the Twister library.

    # Install the necessary software
    echo Installing necessary software
    apt-get update -y
    apt install mitmf mitmflib -y

    #Remove the new, broken Twisted app, and install the old version that works.
    cd /usr/lib/python2.7/dist-packages
    rm -rf twisted/
    rm -rf Twisted-16.3.0.egg-info/

    cd /usr/share/mitmf
    pip install ./Twisted-15.5.0.tar.bz2 --quiet

    cd /usr/share/mitmf
    echo DONE DONE DONE DONE DONE

    #Below is a sample mitmf command. Change the IPs as appropriate.
    #python mitmf.py -i eth0 --spoof --arp --target 123.123.123.123 --gateway 123.123.123.1 --upsidedownternet

  4. #4
    pip install pyinotify
    and try again but by using (python3 mitmf.py)
    but maybe you will never execute it https://raw.githubusercontent.com/by...aster/mitmf.py
    This is an old function that is used only on Python 2.7, and it is deprecated for 2.7.18
    You can write your own
    BR

  5. #5
    Yeah it works fine on Python 2.7 but I am not sure about python3 mitmf.py

Similar Threads

  1. Is not installing mitmf, keimpx and wol-e
    By sadhin in forum App Store
    Replies: 0
    Last Post: 2019-10-11, 17:47
  2. Troubles upgrading and installing new software
    By Phluphphy in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2016-03-04, 15:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •