Hello. Kali noob here, and I'm trying to install Kali Linux alongside Windows 10 on an Acer laptop. I've gotten so far as making a live USB (no persistence), booting a live session from it and resizing the Windows partition in gparted. After that, when I live boot the USB and choose any other option than "Live system" in GRUB there is a graphical glitch. From what I can tell it's displaying an install window (or some other window) but doesn't draw it to the correct width for the screen resolutiongraphicsBug.jpgmenu.jpgadvMenu.jpggraphicsBug.jpgmenu.jpgadvMenu.jpg (and the rest of GRUB) so everything becomes smeared out diagonally to one side (picture attached, graphicsBug.jpg).

To make the bootable USB drive I downloaded (2021-01-05) the "Kali Linux 64-Bit (Live)" from:


and followed the instructions at:


When trying to boot a non-persistent live session with that everything seems to work smoothly and I used that to resize the Windows partition with gparted following the instructions here:


When I get to "Kali Linux Installation Procedure" is when problems start. First of all I have not been able to find an up-to-date guide on how to install from a live USB, so I'm not entirely sure what option to pick in GRUB (which means I've used trial and error and tried several options). All guides I find when se show menus different from the ones I get (pictures attached, menu.jpg and advMenu.jpg) and:


just references:


which assumes I'm using the installer image rather than the live image so I'm not exactly sure what option to pick in GRUB.

If I press Esc after the graphics glitch happens the pixels shift but still retain the erroneously drawn width, which is why I assume this is a window that is being displayed, but since I'm new at Kali I don't know the menus and unfortunately can't navigate them blindly.

I've found several sources saying they're experiencing the same glitch, as far back as 2015, and I've tried the recommended actions, like adding nomodeset in GRUB prior to launching an option, or changing to legacy boot. Neither of those have worked.

The hardware I'm trying to install on is an Acer Travelmate with an i5-3230M CPU, 4 gb RAM and 64-bit Windows 10 Home.

I'd be grateful for any help I can get resolving this.

Best regards.