Hi,

I have just purchased a new Alfa AWUS036ACS USB WiFi adapter to replace an exiting Alfa AWUS036NEH which was only 2.4 Ghz.

The new card ( 36ACS ) seems to have an issue with not working properly in monitor mode. I installed drivers from this link
HTML Code:
http://downloads.fars-robotics.net/wifi-drivers/install-wifi
which has loaded the adapter and i now get an wlan0 interface although it has used the 8812au driver

I was originally running kernel 4.19 but have upgraded to 5.4 to see if it makes any difference which it doesn't. I have also noticed that if i down the interface, set the mode to monitor via
PHP Code:
iwconfig wlan0 mode monitor 
and bring it back up again, then run iw dev the interface is still shown as managed. However if i run
PHP Code:
iw wlan0 set monitor none 
the interface does then show as monitor mode but still no packets captured.

There seems to be a couple of posts here saying they have had similar issues but according to the various reports plus
PHP Code:
iw phy 
the adapter does support monitor mode. I presuming the issue is driver related.

Has anyone had a similar issue and managed to get the adapter working, if so how ?

Thanks