Results 1 to 2 of 2

Thread: Clock displaying incorrect time

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2021-Feb
    Posts
    2

    Clock displaying incorrect time

    Kali clock is not displaying the correct local time.
    Running timedatectl gives the following:

    Local time: Tue 2021-02-23 05:21:36 SAST
    Universal time: Tue 2021-02-23 03:21:36 UTC
    RTC time: Tue 2021-02-23 03:21:36
    Time zone: Africa/Johannesburg (SAST, +0200)
    System clock synchronized: yes
    NTP service: active
    RTC in local TZ: no

    BUT my clock displays 03:21. The Time Zone setting in the Clock properties is set to SAST.

    Any pointers will be appreciated.

  2. #2
    Join Date
    2019-Dec
    Posts
    2
    In the Troubleshooting Achive there is a work around: https://forums.kali.org/showthread.p...509#post104509

    for me it worked for a couple of weeks however today its stopped and have to update manually i.e. date -s '16 June 2021 04:09:00'

    The solution should have worked permanently so not sure why it isn't...

    UPDATE:WORKING AGAIN

    I must have revisited the timesyncd.conf file and accidentally changed something in the NTP=xx.pool.ntp.org. I live in asia and as such NTP=asia.pool.ntp.org. Go to www.pool.ntp.org for timezone NTP servers.
    Last edited by Danjo0368; 2021-06-23 at 01:55.

Similar Threads

  1. Adding a clock time icon to the settings menu
    By dr_set in forum Community Feedback
    Replies: 0
    Last Post: 2020-04-02, 06:27
  2. Replies: 0
    Last Post: 2019-11-03, 07:26
  3. Raspberry Pi 2 clock time and locale
    By Mr Wolf in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-12-07, 16:11

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •