I have installed Kali on WSL and after install I updated and then proceeded to install kali-linux-default, after I did that I am getting install and update issues because there are packages with a "%" in the package name, the main one is the Nmap install.

I tried several things to fix including
sudo dpkg --purge ettercap-common_1%3a0.8.3.1-3_amd64.deb
[sudo] password for username:
dpkg: error: --purge needs a valid package name but 'ettercap-common_1%3a0.8.3.1-3_amd64.deb' is not: illegal package name in specifier 'ettercap-common_1%3a0.8.3.1-3_amd64.deb': character '%' not allowed (only letters, digits and characters '-+._')

also tried

$ sudo apt --fix-broken install
[sudo] password for username:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 51 not upgraded.
1690 not fully installed or removed.
Need to get 0 B/735 kB of archives.
After this operation, 2,578 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
E: Invalid archive signature
E: Internal error, could not locate member control.tar{.zst,.lz4,.gz,.xz,.bz2,.lzma,}
E: Prior errors apply to /var/cache/apt/archives/ettercap-common_1%3a0.8.3.1-3_amd64.deb
debconf: apt-extracttemplates failed: No such file or directory
dpkg-deb: error: '/var/cache/apt/archives/ettercap-common_1%3a0.8.3.1-3_amd64.deb' is not a Debian format archive
dpkg: error processing archive /var/cache/apt/archives/ettercap-common_1%3a0.8.3.1-3_amd64.deb (--unpack):
dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any help is appreciated.