Results 1 to 5 of 5

Thread: Nethunter upgrade error

  1. #1
    Join Date
    2021-Feb
    Posts
    1

    Unhappy Nethunter upgrade error

    I have big problem with my nethunter. When I write sudo apt upgrade. I get it:

    Reading package lists... DoneBuilding dependency tree... DoneReading state information... DoneCalculating upgrade... DoneThe following package was automatically installed and is no longer required: libllvm10Use 'sudo apt autoremove' to remove it.The following packages will be upgraded: postgresql-131 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.Need to get 0 B/14.5 MB of archives.After this operation, 136 kB of additional disk space will be used.Do you want to continue? [Y/n] YPreconfiguring packages ...(Reading database ... 309024 files and directories currently installed.)Preparing to unpack .../postgresql-13_13.2-1_armhf.deb ...invoke-rc.d: could not determine current runlevelStopping PostgreSQL 13 database server: mainError: Data directory /var/lib/postgresql/13/main must not be owned by root ... failed! failed!invoke-rc.d: initscript postgresql, action "stop" failed.dpkg: warning: old postgresql-13 package pre-removal script subprocess returned error exit status 1dpkg: trying script from the new package instead ...invoke-rc.d: could not determine current runlevelStopping PostgreSQL 13 database server: mainError: Data directory /var/lib/postgresql/13/main must not be owned by root ... failed! failed!invoke-rc.d: initscript postgresql, action "stop" failed.dpkg: error processing archive /var/cache/apt/archives/postgresql-13_13.2-1_armhf.deb (--unpack): new postgresql-13 package pre-removal script subprocess returned error exit status 1Errors were encountered while processing: /var/cache/apt/archives/postgresql-13_13.2-1_armhf.debE: Sub-process /usr/bin/dpkg returned an error code (1)

    Could somebody help me? Please

  2. #2
    Join Date
    2021-Sep
    Posts
    1
    I have the same problem.
    I can't upgrade because of this.
    Samsung S10 Android 11 Non Root.

  3. #3
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    326
    Wish i could see the error

    in terminal type

    cat /etc/apt/sources.list

    If nothing shows on screen you need to add a source

  4. #4
    Join Date
    2021-Dec
    Posts
    1

    sub-process error

    Hello,
    I'm also having an issue. Every time I've tried to upgrade I always get this error,
    Sub-process /usr/bin/dpkg returned an error code

    I've tried almost everything that google has and still haven't made any progress.

  5. #5
    Join Date
    2021-Dec
    Posts
    2
    Linux distribution packages can be updated from the terminal with just two commands "sudo apt update" and "sudo apt upgrade".

Similar Threads

  1. Replies: 3
    Last Post: 2016-10-15, 11:57

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •