I am using kali linux on windows subsystem for linux (wsl). I also use the package kali-win-kex to provide myself GUI access to the operatying system.

Today, as usual, after I booted my computer, I executed `sudo apt update` and `sudo apt dist-upgrade`. After that I found I could not launch kex.

Typing `kex` produces the following error message:

Error connecting to the KeX server.
Please try "kex start" to start the service.
If the server fails to start, please try "kex kill" or restart your WSL2 session and try again.

At the same time, in Windows, there is a GUI error message from tigerVNC which said:

unable connect to socket: Connection refused (10061)

I tried `kex start`, `kex kill` and rebooting kali linux wsl2 distribution, none of them works. `kex --status` returns the same error message. However, if I run `vncserver` first, then `kex --status` returns information about that vnc server, for example:

Win-KeX server sessions:

:1 5901 8515 Xtigervnc

You can use the Win-KeX client to connect to any of these displays.

Now, if I execute `kex`, another error message produced by tigerVNC shows in Windows: "No matching security types" and the connection fails.

What's more, `kex --esm` which uses Windows' native RDP could setup the connection, so I guess the problem might be that kex could not setup the VNC server which tigerVNC uses to connect to Kali.

The output of `uname -srm` is

```Linux 4.19.104-microsoft-standard x86_64

and I am using Kali on windows under WSL2 environment.