Results 1 to 6 of 6

Thread: How do i get wireshark to run in promiscuous mode in vmware

  1. #1
    Join Date
    2013-Apr
    Posts
    10

    How do i get wireshark to run in promiscuous mode in vmware

    How do i get wireshark to run in promiscuous mode in vmware - i already have it bridged and not nat and i still can't capture any traffic but my laptop

  2. #2
    Join Date
    2013-Mar
    Posts
    65
    Don't mean to be a ****, but have you tried Google?

    http://lmgtfy.com/?q=How+do+i+get+wi...+in+vmware&l=1

    Thanks,
    Eric

  3. #3
    Join Date
    2013-Apr
    Posts
    10
    Yes i tried google but there doesn't seem to be much there - do you have a solution

  4. #4
    Join Date
    2013-Mar
    Posts
    65
    Did you click the link I provided and look at the first one? Did that work for you? It steps you through what to do on the local Linux system.

    I run vmware on MacBook and normally I get a prompt to enter my MacBook pass to enable promisc mode. But I have not tried directly from wireshark.

    Update:
    OK so all I did was fire up wireshark in my Kali VM, slected eth0 and my macbook prompted me to enter a password to enable promiscuous mode.
    Last edited by brav0hax; 2013-05-12 at 02:58. Reason: update

  5. #5
    Join Date
    2013-Apr
    Posts
    10
    I use vmplayer - Not vm workstation - I forgot to specify that

  6. #6
    Join Date
    2014-May
    Location
    Valencia
    Posts
    48
    Quote Originally Posted by brav0hax View Post
    Don't mean to be a ****, but have you tried Google?

    http://lmgtfy.com/?q=How+do+i+get+wi...+in+vmware&l=1

    Thanks,
    Eric
    Ironic that lmgtfy shows this post as the 2nd search result. Google will often bring back results from forums such as this one, so let's not be jerks and help this guy out?

    I think the problem is mainly due to the way your physical WiFi adapter is presented to the virtual machine in VMware Player. If you can download a trial of VMware Workstation as you can definitely set promiscuous mode with that, and if that fails you might need to use USB passthrough with a compatible USB WiFi adapter, or just boot from the Kali ISO.

Similar Threads

  1. Wireshark in Monitor Mode (LiveDVD)
    By snoop911 in forum General Archive
    Replies: 1
    Last Post: 2015-12-29, 12:56
  2. Replies: 1
    Last Post: 2015-01-27, 13:21
  3. Replies: 4
    Last Post: 2014-10-01, 17:14
  4. Intel Centrino 6200 AGN: promiscuous mode, monitor mode and packet injection
    By forumkali@yopmail.com in forum General Archive
    Replies: 0
    Last Post: 2014-08-20, 07:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •