Morning all

I am really battling to get Kali installed on a micro SD card to use on a Pi4.

I have tried using Kali Linux RPi (img.xz), Kali Linux RaspberryPi 2, 3, 4 and 400 (img.xz) and Kali Linux RaspberryPi 2 (v1.2), 3, 4 and 400 (64-Bit) (img.xz). All three downloads have been hash checked after downloading.
I have tried using Etcher as well as the Raspberry Pi Imager, both on latest release.
I am using a Sandisk Ultra 32Gb micro SD. I have 2 of them and both do the same.
My machine is Windows 10 (2004).

Every image fails to write. Etcher gives an error of flash failed and the Pi Imager just says the written image is different to the verified image when verifying.
When using Etcher I have unzipped the file using the latest version of 7zip and used the img file as well as having tried the xz file direct. Either way I have the same result.

I have downloaded an image of Raspios and that flashes fine to both SD cards which would tend to prove the cards are OK.

I do however only have one converter from SD to USB but that works using any non Kali images so I am doubtful that is the issue.

I am totally stuck about what more to try to get Kali going.
Anybody have any advice?

Thanks in advance