Results 1 to 10 of 10

Thread: Hybrid Graphics Intel HD 3000 / Radeon HD 6630M - Can't find drivers.

  1. #1
    Join Date
    2013-Mar
    Posts
    23

    Hybrid Graphics Intel HD 3000 / Radeon HD 6630M - Can't find drivers.

    Hello everyone,

    Sorry for posting this again and making a new thread for it, but I never got any answer the last time I did it.

    I added:

    "deb http://ftp.debian.org/debian/ experimental main non-free contrib" this to my sources.list and ran

    sudo apt-get -t experimental install fglrx-driver fglrx-control
    sudo apt-get -t experimental install amd-opencl-icd
    aticonfig --initial -f

    it worked for me before, but then i reinstalled Kali Linux and now I get the message:
    "E: The value 'experimental' is invalid for APT:efault-Release as such a release is not available in the sources"

    I also tried to run:

    sudo apt-get install fglrx-driver fglrx-control - Didn't work.

    Also I tried to install drivers from AMD's site - Didn't work.


    Is there someone who know what I can do please?

  2. #2
    Join Date
    2013-Mar
    Posts
    269
    Did you run 'apt-get update' after you edit your sources?
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  3. #3
    Join Date
    2013-Mar
    Posts
    23
    Quote Originally Posted by charonsecurity View Post
    Did you run 'apt-get update' after you edit your sources?
    WoW mate thanks I am such a noob you fixed my problem thanks so much for answer and for fast reply, I really appreciate, thank you

  4. #4
    Join Date
    2013-Mar
    Posts
    23
    Waaaaaaaaaaa, it still didn't work everything was installed and then I reboot and got blackscreen on startup

  5. #5
    Join Date
    2013-Mar
    Posts
    269
    It may be several reasons for the black screen at start up after you installed the drivers. Check to make sure its just not the brightness is all the way down (happens to HP computers for some reason, not sure if you have that or not).. Also you may want to try in grub setting the nomodeset command.
    From the Grub boot window, select the entry you want to boot.
    Type 'e' to edit the boot entry.
    Find the line starting with 'linux' (a long line with a lot of entries) and move your cursor to the end of the line.
    Type 'nomodeset' (without the quotes)
    Enter Ctrl-X to save the changes and reboot.
    Grub boots normally.
    Not sure if this is the correct fix.
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  6. #6
    Join Date
    2013-Mar
    Posts
    23
    Quote Originally Posted by charonsecurity View Post
    It may be several reasons for the black screen at start up after you installed the drivers. Check to make sure its just not the brightness is all the way down (happens to HP computers for some reason, not sure if you have that or not).. Also you may want to try in grub setting the nomodeset command.
    From the Grub boot window, select the entry you want to boot.
    Type 'e' to edit the boot entry.
    Find the line starting with 'linux' (a long line with a lot of entries) and move your cursor to the end of the line.
    Type 'nomodeset' (without the quotes)
    Enter Ctrl-X to save the changes and reboot.
    Grub boots normally.
    Not sure if this is the correct fix.

    I tried it with 'nomodeset' but still no luck. I'm getting a black screen, with a white cursor top left corner instead of normal Kali login screen.

  7. #7
    Join Date
    2013-Mar
    Posts
    269
    how about with "i915.modeset=1".. I don't know if that will work, though it did for backtrack.
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  8. #8
    Join Date
    2013-Mar
    Posts
    23
    Quote Originally Posted by charonsecurity View Post
    how about with "i915.modeset=1".. I don't know if that will work, though it did for backtrack.
    I tried it, still no luck thanks anyways

  9. #9
    Join Date
    2013-Mar
    Posts
    23
    *SOLVED*

    Awieeee, I just solved my problem or rather found help to solve it

    I followed this guide: http://www.kalilinux.net/community/t...ali-linux.108/

    and got it working

  10. #10
    Join Date
    2014-May
    Posts
    10
    so how you fix your problem?
    I ask cos i have the same problem just like yours and the link is not work.

Similar Threads

  1. Hybrid Intel/ATI graphics drivers on a full install on Dell laptop.
    By Futurist in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-06-24, 12:54
  2. Hybrid Graphics problem - Intel HD 3000 / AMD Radeon HD 6630
    By Kraako in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-03-29, 14:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •