Hi Kali community!

I installed Kali Linux 2021.1 on my USB yesterday and tried to launch it on my MacBook Pro 13' running on Catalina.
Everything works pretty well, until I try to connect to wifi, so here is the issue:

- When going to wifi settings, the available spots are correctly listed, and I can see the one I want to connect to
- When trying to connect to it with my password, it loops to the password window, just as if the password wasn't correct (which it is, I can assure that)
- I tried to investigate to see the state of the wifi in the terminal, wlan0 appears when writing ipconfig
- However, when doing ip a, wlan0 appears with state DOWN, though I have
- I tried to change the state to up with the commands
sudo ipconfig wlan0 up
sudo p link set wlan0 up
but nothing works, the state stays DOWN
- Ethernet works well, so I can have an internet access if needed
- I searched all over the web and found nothing about this issue (Though wifi problems seems something pretty common on MacOS)

If you have any idea of additional investigation or ways to tackle the problem, I would be very grateful, 2 days that I struggling with that without being able to move forward.

Thanks in advance !