Results 1 to 1 of 1

Thread: Kali won't upgrade

  1. #1
    Join Date
    2021-Sep
    Posts
    1

    Exclamation Kali won't upgrade

    I've installed kali linux onto a 256 gb sdcard for use on a Raspberry Pi 4. I used the pre-made image for the rapsberry pi 4 from the downloads page, and balenaEtcher to flash it to the card. After installation it boots up fine, but when I run "apt update && apt upgrade" (as sudo) it gives me the error "E: You don't have enough free space in /var/cache/apt/archives/.". This is a 256 gb sdcard so space shouldn't be an issue. When I check it using disk management on windows it shows that 233 gb is a separate partition from the kali linux partition, which is less than 10 gb. Disk management doesn't allow me to extend the kali partition to use the full space, nor does a third party partition manager, and I've tried wiping and formatting the sdcard and reinstalling, but it only gives me the same errors. Any help would be much appreciated.
    Last edited by tacc159; 2021-09-08 at 04:01.

Similar Threads

  1. Kali Live via USB --> not enough storage space
    By th-vb in forum Installing Archive
    Replies: 13
    Last Post: 2017-11-12, 19:58
  2. No Storage Space after "apt-get upgrade" command
    By Elite in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-04-02, 23:01
  3. Storage space after installing nethunter?
    By redhern in forum NetHunter General Questions
    Replies: 4
    Last Post: 2015-02-01, 04:18
  4. Boot from USB while still keeping some space storage
    By TumbaBit in forum Installing Archive
    Replies: 1
    Last Post: 2013-12-28, 11:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •