Hi Everyone,

I've faced a small issue with setting up resolution on Kali Linux VM - Hyper-V based.
I've found an article on this forum How can I change the screen size (kali.org) but the question was not fully solved so I tested a bit and found a solution - steps below:

a) Run "Terminal"
b) sudo vi /etc/default/grub
c) GRUB_CMDLINE_LINUX_DEFAULT="quiet" change to d) or e) just specify the required resolution you prefer
d) GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=hyperv_fb:1920x1080"
e) GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=1920x1080"
e) :wq
f) sudo update-grub (this part was mainly missing in the original post, you need to update/apply configured settings in GRUB - writing :wq the changes itself is not enough)
g) Reboot

That way it works.

By the way: Enabling/disabled the RemoteFX Adapter in the Hyper-V settings doesn't work - it is not supported by Microsoft Hyper-V anymore.

Microsoft info: WARNING: We no longer support the RemoteFX 3D video adapter. If you are still using this adapter, you may become vulnerable to security risks. Learn more (https://go.micr