Hi all,

I have this redundant issue with my bootable USB kali, which has happened 3 times in the last few days.

I have a USB bootable persistence of Kali 2021.3 on a SanDisk MicroUSB (32GB and 128GB, have copies of kali on both cards with the same issue).

uname -a
Linux Kali 5.10.0-kali9-amd64 #1 SMP Debian 5.10.46-4kali (2021-08-09) x86_64 GNU/Linux

Pretty much what happens is that when I upgrade - full-upgrade - distro-upgrade, after a few minutes my internet access drops. I have wifi connection to the router, I am able to ping the gateway, able to ping 8.8.8.8 and 1.1.1.1, but have no external internet access, and I am unable to ping any other address.
when ping google.com, it returns:
Temporary failure in name resolution.
Not sure if worth saying, but I have installed and run NordVPN, and I am in Australia.

DNS is generated by nordvpn

I tried using the SD from different machines and using different wifi adapters, but no luck - if I run Kali in live mode, there is internet connection, so I believe the issue is in modified settings, either from the VPN or from the updates.
I have 3 different microSD with 3 copies of Kali that decided to have the same behaviour over the last few days, is there any known issue or solution?
I have copies of Ubuntu running with the same VPN account and from the same machines and connection and have no issue with those, just Kali.

At this stage I think is not worth it for me to keep creating new copies, but rather find the solution.
I'll share any required log.

Thank you for your help.