Results 1 to 6 of 6

Thread: RFKill non existant SOICSIFFLAGS error, stuck in airplane mode

  1. #1
    Join Date
    2013-May
    Posts
    6

    RFKill non existant SOICSIFFLAGS error, stuck in airplane mode

    When entered ifconfig wlan0 up it returns siocsifflags not possible due to rfkill

    The normal fix with rfkill it says command not found.

    Airplane mode in system settings reverts to on after I leave the menu and it refuses to let me switch on the wireless interface in that menu regardless of the airplane mode status.

    I've also tried (http://forums.kali.org/showthread.ph...-to-RF-kill%94) with no luck.

    Any help with this would be appreciated.

  2. #2
    Join Date
    2013-Mar
    Posts
    269
    If I understand correctly, your wireless lan has a block in place?
    If you can, what is the output of this command, "rfkill list".. I assume it says their is a soft block or hard block in place? and the command "rfkill unblock all" doesn't fix your issue?

    Also make sure (on some notebooks) that the physical toggle key is not the culprit, i.e. (Function Key + Wireless), or some other physical toggle key.
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  3. #3
    Join Date
    2013-May
    Posts
    6
    Quote Originally Posted by charonsecurity View Post
    If I understand correctly, your wireless lan has a block in place?
    If you can, what is the output of this command, "rfkill list".. I assume it says their is a soft block or hard block in place? and the command "rfkill unblock all" doesn't fix your issue?

    Also make sure (on some notebooks) that the physical toggle key is not the culprit, i.e. (Function Key + Wireless), or some other physical toggle key.
    You are correct.
    It says "rfkill command not found." Normal fix doesn't work because of this.
    There isn't a physical block.
    Last edited by kaliquestion; 2013-05-16 at 13:30.

  4. #4
    Join Date
    2013-May
    Posts
    11
    Seems the only way now is to reboot, I'll post the solution after finding the bug later

  5. #5
    Join Date
    2013-Mar
    Posts
    269
    go ahead and install it with this command, "apt-get install rfkill" or "aptitude install rfkill" then try again.
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  6. #6
    Join Date
    2013-Aug
    Posts
    6
    APPLICATIONS MENU > SYSTEM TOOLS > PREFERENCES > SYSTEM SETTINGS

    open NETWORKS

    Now, toggle the AIRPLANE mode off and while it is still open (leave it alone) press your standby/power button. Let the system go into standby. Next resume the system and toggle your wifi button.

    Worked for me.

Similar Threads

  1. WiFi hardware blocked. RFkill not working.
    By idetuxs in forum TroubleShooting Archive
    Replies: 15
    Last Post: 2016-04-29, 17:46
  2. browser error in VNC mode
    By zerone.v01d in forum NetHunter General Questions
    Replies: 2
    Last Post: 2015-02-19, 04:33
  3. Replies: 10
    Last Post: 2014-04-24, 10:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •