Results 1 to 7 of 7

Thread: No ethernet card detected and no WiFi Surface Book 1 [Dual Boot Windows 10 and Kali Linux]

  1. #1
    Join Date

    No ethernet card detected and no WiFi Surface Book 1 [Dual Boot Windows 10 and Kali Linux]

    I am trying to dual boot Kali Linux with Windows 10 on my Microsoft Surface Book 1 laptop.

    I went through the following steps:
    1. I downloaded kali linux using the torrent version at this link
    2. I used Rufus to create a bootable usb drive using the downloaded iso
    3. I rebooted and started installing the iso on an empty partition with 30 GBs

    I faced 3 problems during installation:

    1. The Network Card was not detected and I was prompted with the following message:
    "Some of your hardware needs non-free firmware files to operate. The firmware can be loaded from removable media, such as USB stick or floppy.
    The missing firmware files are: mrvl/pcie8897_uapsta.bin
    If you have such media available now, insert it, and continue.
    Load missing firmware from removable media? (No, Yes)"

    2. The network card was not listed and I could not choose any network card manually

    3. Installing the following (Xfce, --top10 -- the most 10 popular tools, --default-- recommended tools) showed an error and could not be installed. Only installing GNOME worked.

    Solutions I tried:
    I downloaded the file mrvl/pcie8897_uapsta.bin and copied it on another USB and plugged it while installing but the same message showed again. I searched for similar problems and what I found is that this message is misleading and there might be other needed files. So, I was stuck here and could not continue.

    I did the following:

    1. As advised in many forums, I just chose No when loading missing firmwares. I read many forums telling that we can install the missing files later after booting.

    2. The installation continued and when I could not choose any network drive from the list, I chose: No network adapter

    3. I chose GNOME only and the installation continued

    The Dual Booted successfuly and I could open Kali linux. However, as expected, WiFi was not connected -obviously because the network drive was not installed-
    The suggested solutions for this were connecting throught an ethernet cable. The bigger problem is that in the Surface Book, there is no ethernet cable. So, I thought about using a USB-2 to ethernet converter. So, I used "KY-RD9700 USB2.0 to Fast Ethernet Adapter Converter". This solution did not work as well. My assumption is that this happened because of not detecting the network drive in the first place. The adapter also needed installation and I found no linux installation for it.

    Many solutions suggest that I need to do some commands like: apt get update and apt get upgrade. This sounds great but I do not have internet on my machine. No WiFi and no ethernet cable connected.

    Some of the linux commands such as "ifconfig" are not working as well. I assume this is because not being able to install the default or top10 tools during installation.

    My network card drive is: Marvell AVASTAR Wireless-AC Network Controller

    I am stuck now and I can not find more help any where.

  2. #2
    Join Date
    Hi. The solution is to put the missing driver in the firmware folder of the USB where you are installing Kali Linux. So when the installation starts it will detect the drivers and it won't give you any problems.

  3. #3
    Join Date
    how will i enable my kali to internet.....i am using kali on hyper V ....and im unable to to get my kali box connected to internet....

  4. #4
    Join Date
    I have the same probleme but I don't know where I can download the drivers

  5. #5
    Join Date
    After spending hours trying to fix this firmware error, I decided to ignore the error, and use an external USB to Ethernet adapter.
    This firmware update seems to only impact the network driver.
    I plan to fix driver issues later.

    Hope this helps.

  6. #6
    Did you find a solution to this? I'm in the exact same boat. I even put all the necessary files in all the necessary folders on the boot drive and still nothing works.

  7. #7
    Join Date
    Non free firmware is NOT included in any Debian based installer by default, you need to download the 'non free firmware files' and then on Another USB stick (Fat32 formatted) to the installer, unpack them to a folder named firmware

Similar Threads

  1. HD not detected during installation dual boot windows 10
    By Bscope in forum Installing Archive
    Replies: 0
    Last Post: 2022-02-15, 22:59
  2. Dual boot Kali and Windows 10 on Surface Pro 2?
    By dsound in forum Installing Archive
    Replies: 0
    Last Post: 2016-04-16, 22:17
  3. Replies: 3
    Last Post: 2014-06-01, 21:04

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts