Results 1 to 4 of 4

Thread: UI values representing date/time/workspace etc. turn into characters during and after upgrade

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date

    Exclamation UI values representing date/time/workspace etc. turn into characters during and after upgrade

    So I thought may this was an isolated issue but I have encountered it during two different installs using two different devices.

    After I run sudo apt-get upgrade, while all the necessary processes take place - the values representing time, date, workspace session all turn into characters like apostrophes, underscores etc.

    I first experienced this when trying to update kali on an RPi 4 which faces other issues during upgrade however its difficult to say why the UI is affected.

    Thought to try a regular kali build on VMWare and the issue persists on the VM as well.

    Devices used:
    Raspberry Pi 4 - 4GB and 8GB models using ARM image on
    VM - running on VMWare using VMWare image on

    Both are 64 bit architectures.

    The issue happens after trying to update a fresh install (image obtained from with no additional changes or customisations)

    I've attached a screenshot where if you look at the taskbar on the top - you'll see where there are supposed to be numbers representing workspace sessions (i.e. 1,2,3,4) are now ', ., ", -

    You can also see to the top right where the time and date are supposed to be displayed, the characters display instead of actual numerical values representing time and date.

    The screenshot is obtained from VMWare but it also represents exactly the issue I face on the ARM build as well after 'upgrading'.

    FYI: I run sudo apt-get update before running sudo apt-get upgrade
    Attached Images Attached Images

  2. #2
    Hi Bravo,

    Ditto, we have had a number of machines do the same, and not just new installs either, what is more weird is that it happens on VMs, physical machines, old and new installs. So if someone does know how to resolve this it would be appreciated.

  3. #3
    BTW it's not just numeric characters on our installs, it's some special characters as well.

  4. #4
    OK, I certainly seem to have resolved our issues. We ran the following:

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade
    sudo reboot now

    It has fixed all of our machines.

Similar Threads

  1. Replies: 2
    Last Post: 2023-04-12, 02:23
  2. Date and time wrong and cant fix
    By solo7777 in forum General Archive
    Replies: 0
    Last Post: 2021-09-20, 06:24
  3. Problems With Wi-Fi and Date & Time
    By eddie@kali in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2021-05-10, 13:23
  4. Date Time change
    By AlacJ in forum General Archive
    Replies: 4
    Last Post: 2020-01-13, 18:53
  5. Date and time
    By martinii in forum ARM Archive
    Replies: 1
    Last Post: 2017-02-03, 20:38

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts