I'm fairly new to kali-linux, so I apologize for my lack of expertise.

I had installed Kali-Linux and Ubuntu successfully and updated everything. However, when installing Packages [https://www.kali.org/docs/general-use/metapackages/] for Kali (only had the bare minimum of Kali installed) I came upon an issue, in every successive package un-met dependencies kept popping up that wouldn't be installed, no matter the package they would lead back to a package called 'set' that wouldn't install (its part of the kali-linux-headless package install). Working in root. [https://www.kali.org/tools/set/]

When trying to fix the install of 'set' this happens in the code below.

It LOOKS like an issue with the archive not being in Debian format, but I'm honestly not sure what the actual issue is or how to fix it.

  1. I've tried re-installing 'headless' and associated packages.
  2. Searched online for the issue but came up with this issue happening for custom-packages in the file being 'broken'.
  3. Also have tried getting a new Key for the archive signature error. [https://unix.stackexchange.com/quest...natures-were-i]

Would love any advice anyone could provide or direct me to for this

sudo apt install set
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Suggested packages:
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    1393 not fully installed or removed.
    Need to get 0 B/39.4 MB of archives.
    After this operation, 50.9 MB of additional disk space will be used.
    E: Invalid archive signature
    E: Internal error, could not locate member control.tar{.zst,.lz4,.gz,.xz,.bz2,.lzma,}
    E: Prior errors apply to /var/cache/apt/archives/set_8.0.3+git20200609-0kali2_all.deb
    debconf: apt-extracttemplates failed: No such file or directory
    dpkg-deb: error: '/var/cache/apt/archives/set_8.0.3+git20200609-0kali2_all.deb' is not a Debian format archive
    dpkg: error processing archive /var/cache/apt/archives/set_8.0.3+git20200609-0kali2_all.deb (--unpack):
     dpkg-deb --control subprocess returned error exit status 2
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)