Results 1 to 2 of 2

Thread: Can't upgrade keeps showing this: Failed to activate service 'org.freedesktop.systemd1': timed out

  1. #1
    Join Date
    2014-Mar
    Posts
    8

    Can't upgrade keeps showing this: Failed to activate service 'org.freedesktop.systemd1': timed out

    Hello, wanted to upgrade Kali so following this: https://www.kali.org/docs/general-use/updating-kali/

    Downloaded all the files but when installing keeps showing this message:

    Code:
    Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
    And it just exits the upgrade, so I rebooted and everything seems to be fine, but since it never finished the upgrade I typed:
    Code:
    $ sudo apt --fix-broken install
    [sudo] password for tony: 
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      at-spi2-core libaom0 libcodec2-0.9 libdap27 libdapclient6v5 libdav1d4 libepsilon1 libgdal28 libgeos-3.9.0 libnetcdf18 libproj19 libpython3.9-dev libqhull8.0
      librest-0.7-0 libtbb2 liburing1 libx265-192 libyara4 odbcinst odbcinst1debian2 python3-editor python3-humanize python3-llvmlite python3.9-dev
    Use 'sudo apt autoremove' to remove them.
    The following additional packages will be installed:
      libapache2-mod-php libdaxctl1 libndctl6 libpmem1 mariadb-client-10.6 mariadb-client-core-10.6 mariadb-server-10.6 mariadb-server-core-10.6 php-mysql
      php8.1-mysql
    Suggested packages:
      mailx mariadb-test netcat-openbsd
    The following packages will be REMOVED:
      mariadb-client-10.5 mariadb-client-core-10.5 mariadb-server-10.5 mariadb-server-core-10.5 php7.4-json php7.4-mysql
    The following NEW packages will be installed:
      libdaxctl1 libndctl6 libpmem1 mariadb-client-10.6 mariadb-client-core-10.6 mariadb-server-10.6 mariadb-server-core-10.6 php8.1-mysql
    The following packages will be upgraded:
      libapache2-mod-php php-mysql
    2 upgraded, 8 newly installed, 6 to remove and 884 not upgraded.
    836 not fully installed or removed.
    Need to get 0 B/13.7 MB of archives.
    After this operation, 3,583 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Preconfiguring packages ...
    (Reading database ... 345750 files and directories currently installed.)
    Removing mariadb-server-10.5 (1:10.5.8-3) ...
    Failed to stop mariadb.service: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
    See system logs and 'systemctl status mariadb.service' for details.
    dpkg: error processing package mariadb-server-10.5 (--remove):
     installed mariadb-server-10.5 package pre-removal script subprocess returned error exit status 1
    dpkg: too many errors, stopping
    Failed to reload daemon: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
    Failed to reload daemon: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
    Failed to get unit file state for mariadb.service: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
    Failed to retrieve unit state: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
    mariadb.service is a disabled or a static unit, not starting it.
    Errors were encountered while processing:
     mariadb-server-10.5
    Processing was halted because there were too many errors.
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. #2
    Join Date
    2014-Mar
    Posts
    8
    I just turned on Kali and typed again: sudo apt --fix-broken install, just to see someting new and surprisingly it started to fix the install

    After that: sudo apt upgrade, to upgrade all the packages

    Then: sudo apt autoremove, to remove unused packages

    Making sure everything upgraded: apt --upgradable, it showed 5 packages not upgraded, typed again: sudo apt upgrade, it says that there are 5 not upgraded, so I had to upgrade each one, 3 were wine so I typed: sudo apt upgrade wine

    The other 2 were related to Kali so I typed one of them: sudo apt upgrade kali-linux-headless

    Ok, again typed: sudo apt autoremove

    And now seems that everything was upgraded because it does not complain with packages anymore

    Last is to verify the versions:

    Code:
    $  grep VERSION /etc/os-release
    VERSION="2022.2"
    VERSION_ID="2022.2"
    VERSION_CODENAME="kali-rolling"
    Code:
    $ uname -v
    #1 SMP PREEMPT Debian 5.16.18-1kali1 (2022-04-01)
    Code:
    $  uname -r
    5.16.0-kali7-amd64

    So for now everything it's working

Similar Threads

  1. systemd-logind.service failed
    By glassofsound in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-05-20, 05:19
  2. dhclient : Job for smbd.service failed
    By simb2015 in forum General Archive
    Replies: 2
    Last Post: 2016-02-28, 19:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •