Hello everyone, I'm "new" to the forum as I don't remember my old account name.

So I have a full disk install on an Acer gaming laptop from a few weeks ago. I finally got everything set up how I like it (KDE, Latte Dock, OpenSnitch, VB Vms for various things, encryption, etc.) and now I'm having wifi problems.

It first started two days ago. I left my VPN connection going and it has some "killswitch" functionality that I thought was the culprit. I was also connected to my Android's hotspot. I was doing a large file download and woke up to the download failing and no longer having internet access on several connections.

So I thought it was the VPN. I purged it (Torguard), as well as OpenVPN and Wireguard in case there were settings stored somewhere. It didn't help.

Right now, the only AP that has internet access is a shared connection from my other computer. Connecting directly to that AP gives me a redirect to a login page that fails. It just says unable to connect after putting in my login credentials, yet works on my Windows machine.

I've done everything I could think of in order to fix this. I even added a USB wifi dongle and installed the drivers for it. Both cards work and connect but have the same issues.

I did check out https://forums.kali.org/showthread.p...Network-Access and various other pages with minor success.

I will post outputs when I get back on that machine later. Right now I'm typing this from the Windows box as I have some homework I have to do tonight.

- I don't have dnsmasq or anything else handling dns queries installed. I am using NetworkManager settings and have tried with and without as a DNS server. I'm using DHCP. I don't have any caches to clear like Windows but tried clearing my ARP cache with no luck.
- I have edited resolv.conf to have as a DNS server. I had to do this when I first installed and it worked, but now it doesn't.
- I can ping myself, my external IP, and the gateway but it will time out before reaching the host. I can sometimes traceroute external IPs but it usually takes forever and then doesn't work. Websites will give me an "unable to resolve hostname" error.

I finally tried "EasyTether" on Android and with the Linux deb file. It would connect and showed up in my networks. I had an assigned IP but it still wouldn't ping or connect to any network.

I do have OpenSnitch installed but I have tried it disabled and everything that should go through does. It'll ask me for authorization every time.

Again, this laptop was working on my Android hotspot. The network I'm sharing to it works just fine but the laptop cannot directly connect and have internet access. It did load the portal and allowed the login to just give "unable to connect" messages for everything. Ping didn't work, either.

- The other issue is network speed/latency. I have a network widget that shows a graph of the speeds and I have over 200 ms latency on every connection. The speeds will go from 0 - 200 Kbps then fluctuate, randomly dropping to 10-15 Kbps then going back up later. This is on every network and with both the internal Wifi card and the USB wifi dongle. Are there any settings that handle that? I use TCP Optimizer from Major Geeks/Speed Guide on Windows that lets you adjust things like that.