• ro.vendor.build.fingerprint: [OnePlus/OnePlus2/OnePlus2:6.0.1/MMB29M/1447858500:user
  • ro.product.model: [ONE A2003]

  • ro.lineage.display.version: [16.0-20200418-NIGHTLY-oneplus2]
  • Nethunter OnePlus2 official Image flashed with TWRP

I have done:

1) Setup ssh-keygen on server: generates both id_rsa & id_rsa.pub in ~/.ssh
2) Setup ssh-keygen on client: generates both id_rsa & id_rsa.pub in ~/.ssh
3) Copied ~/.ssh/id_rsa.pub from Client to Server manually using adb:
HTML Code:
adb push id_rsa.pub /sdcard/ 
adb shell
input text "rm ~/.ssh/id_rsa.pub && cp id_rsa.pub ~/.ssh/" && input keyevent 66
4) Edited Server /etc/ssh/sshd_config:
HTML Code:
PermitRootLogin yes
PubkeyAuthentication yes
PasswordAuthentication no
UsePAM yes
5) Edited Client /etc/ssh/ssh_config:
HTML Code:
PasswordAuthentication no
Tried to login: ssh, but the result remains (Permission denied (publickey).

I even have tried to remove PubkeyAuthentication for a second, to allow a completely open connection to ssh, but it still returns an access denied error.

Running ssh -vvv shows that:

debug1: Host '' is known and matches the ED25519 host key.

I am not sure what else to do, am I doing something wrong?