Results 1 to 2 of 2

Thread: puzzling boot issues with RasPi4b/8GB after kernel update: USB-C-OTG networking seems broken

  1. #1

    Exclamation puzzling boot issues with RasPi4b/8GB after kernel update: USB-C-OTG networking seems broken

    Setup: RasPi 4b w/ 8GB RAM booting of USB3 SSD

    What worked: booting with the old 5.4.83:
    • both with screen attached, or headless
    • powered by USB powersupply, or by computer

    What works: booting with the new 5.10.103:
    • both with screen attached, or headless
    • only powered by computer

    It was difficult to track this down, because it was just due to the setup I have, that hooking the RasPi up to the screen meant I powered it for convenience from the computer. So at first it seemed the booting was dependent on a screen being attached, so I chased the wrong leads.

    In reality, it's the power source, but that likely has a different reason:

    I have USB-C networking enabled, so I can travel with the RasPi and hook up an iPad Pro with MagicKeyboard and access the RasPi with a fast, secure connection by xrdp via USB-C networking, and power the RasPi over the same cable (iPad Pro can easily be powered in turn by the USB-C port on the MagicKeyboard, but I digress...)

    So what seems to have happened: with the change in kernel from 5.4.83 to 5.10.103, and the corresponding other updates, the USB-C-OTG networking was messed up. When enabled, the system only seems to boot when connected to a computer or some sort of USB host.
    But as if that weren't enough: when that's the case, ifconfig reports the interface being up:

    usb0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500        inet  netmask  broadcast
            ether 8a:d5:e4:fe:32:ef  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    But the host (in my case a Mac) sees the device as down.

    So there have been some significant changes/bugs introduced with the latest updates, in that USB-C-OTG networking seems to be broken in significant ways...

    There's one other option: that the way to enable/setup USB-C-OTG networking as significantly changed, but I'm not aware of any relevant changes in that regards.

  2. #2
    Well, things got more interesting: this seems to be a CABLE issue.
    But it's not a bad cable: the cable worked fine with the old kernel, the cable works fine with drives on my Mac, the cable works fine for the initial boot.

    So, my new working theory: RasPi 4 boots, and at some point switches to a high-power mode, notices the cable isn't designed for the kind of power requested, and halts the system.

    It's not a shutdown, power LED still on, initial booting works; what's what made it so difficult to attribute it to the cable, especially given that the very same cable worked right up until the kernel update.

    So: does anyone know what changed? Is there something that would support my theory?

    PS: the issue with USB-C networking not working properly remains, but that seems to be independent from the boot issue, which is cable dependent, and thus (as my new working hypothesis) a matter of power delivery.

Similar Threads

  1. iwlwifi broken - Kernel 5.2
    By rekondo in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2020-01-27, 14:21
  2. Replies: 6
    Last Post: 2014-01-15, 21:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts