Results 1 to 2 of 2

Thread: TP-Link DWA-171 not working on Virtual Box - Kali

  1. #1
    Join Date

    TP-Link DWA-171 not working on Virtual Box - Kali

    Good day,

    Kernel version:

    uname -r

    Already did sudo apt update
    And also sudo apt full-upgrade

    Source of it is the kali-rolling

    I have an issue with getting my DWA-171 wifi adapter to work on Kali on Oracle VBox
    I have followed some threads on getting this resolved but with no luck at all

    Problem getting D-Link DWA 171 to work - Linux Mint Forums
    I also tried with rtl8812au.ko and pasted it in /lib/modules/5.18.0-kali2-amd64/kernel/net/wireless/ - and then reboot but with no luck again
    I have tried with manual install and copy the ko file into the correct path and reboot the kali VM as well as unplug - re-plug the USB but still nothing: The light on the USB doesn t turn on.
    On the network icon it doesn t even show wifi
    I have tried the usb switch but still no luck getting messages below:

    # sudo usb_modeswitch -KW -v 2001 -p 331d
    Take all parameters from the command line

    * usb_modeswitch: handle USB devices with multiple modes
    * Version 2.6.1 (C) Josua Dietze 2017
    * Based on libusb1/libusbx


    DefaultVendor= 0x2001
    DefaultProduct= 0x331d


    Look for default devices ...
    found USB ID 2001:331d
    vendor ID matched
    product ID matched
    found USB ID 8087:0a2a
    found USB ID 0bda:0153
    found USB ID 80ee:0021
    found USB ID 1d6b:0001
    Found devices in default mode (1)
    Access device 006 on bus 001
    Get the current device configuration ...
    Current configuration number is 1
    Use interface number 0
    with class 255
    Error: can't use storage command in MessageContent with interface 0; interface class is 255, expected 8. Abort

    ** In my virtual machine Kali I have added the DWA-171 usb which it does see it and turned it on from USB side
    I ran then a lsusb and i got the below

    rfkill list && lsusb && mokutil --sb-state
    0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    Bus 001 Device 006: ID 2001:331d D-Link Corp. DWA-171
    Bus 001 Device 004: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
    Bus 001 Device 003: ID 0bda:0153 Realtek Semiconductor Corp. 3-in-1 (SD/SDHC/SDXC) Card Reader
    Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    EFI variables are not supported on this system

    So it looks like the virtual machine and kali does see the bus
    However the wi-fi is not on and as if it doesn't see it:

    lo no wireless extensions.

    eth0 no wireless extensions.

    I feel like i am missing something...but not sure what or how to fix

    Help would be greatly appreciated.

  2. #2
    Join Date
    That adapter is based on the rtl8812AU chipset so you need to install some drivers in Kali, have a look here;

Similar Threads

  1. Replies: 0
    Last Post: 2020-06-21, 00:46
  2. Virtual Console not working and Extended Display not working
    By Nergalwaja in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-04-05, 15:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts