Results 1 to 2 of 2

Thread: 20snapd.conf:3: Extra junk after value

  1. #1

    Exclamation 20snapd.conf:3: Extra junk after value

    Hello everyone,

    I recently came up with the following problem:

    I am booting on a persistent USB Kali Linux 2022.2 USB drive.
    Graphical server does not start as shown in the booting informations
    gnome won't start.JPG

    I used ctrl+ alt + f2 to use the terminal. But a lot of the programs are not accessible.
    dmesg does not work, as weel as other commands.
    /var/log/dmesg does not exist

    I tried to use "systemctl status gdm.service", here is the output:
    sytemctl output.JPG
    I got the same error message for dmesg

    I did:
    cat /etc/apt/apt.conf.d/20snapd.conf
    and got some weird output probably something like hexadecimal.
    Could anyone check their file and show me how you file looks like?

    I recently updated/installed snap and/or snapd so it may be related to that.

    Trying to use "apt" end up showing me the same error message (command not found and problem with this 20snapd.conf file)
    ==> So I can't do "sudo apt remove snap"

    Tried to find troubleshooting linked to thoses error messages on Google but found nothing.

    Please any suggestion is welcomed. Thanks

  2. #2
    Join Date
    for starters you say you've tried systemctl yet in your images you haven't, youve put systemct
    so its going to error..

Similar Threads

  1. Replies: 0
    Last Post: 2022-01-20, 00:57
  2. initramfs unpacking failed: junk within compressed archive. ASAP
    By Miroslav in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2021-12-28, 13:27
  3. 1 Extra Wireless AP alongside wifiphisher
    By demonarkham in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-05-22, 08:58

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts