Results 1 to 4 of 4

Thread: Rootless nethunter install error: no such file kali-arm64/usr/bin/sudo

  1. #1
    Join Date
    2022-Jul
    Posts
    3

    Question Rootless nethunter install error: no such file kali-arm64/usr/bin/sudo

    Hello, I'm running GrapheneOS on a Pixel 6 and am having some issues installing rootless nethunter. I've followed the instructions here https://www.kali.org/docs/nethunter/nethunter-rootless/ but when I try to run the install script I get the error "chmod: cannot access 'kali-arm64/usr/bin/sudo': no such file or directory". Using find I cannot seem to locate the `kali-arm64` directory which leads me to believe the chroot isn't properly getting created. Has anyone else encountered this issue? I've found several posts about this on a related GitHub issue but no solutions: http://https://github.com/Hax4us/Net...mux/issues/147. I've tried rerunning the script multiple times, both with and without deleting and redownloading the kali image. I've also tried to directly download the kali image and running the script but again I see this same error.

  2. #2
    Join Date
    2022-Jul
    Posts
    3
    I realize now I had the Graphene OS setting enabled to block native debugging. Disabling that security feature fixed my error.

  3. #3
    Join Date
    2021-May
    Location
    UK
    Posts
    782
    The install will be stopped by Google Play security every time... even if you disable it.. might take a couple of goes..

    Just follow the manual steps listed;


    • Install the NetHunter-Store app from store.nethunter.com
    • From the NetHunter Store, install Termux, NetHunter-KeX client, and Hacker?s keyboard Note: The button ?install? may not change to ?installed? in the store client after installation - just ignore it. Starting termux for the first time may seem stuck while displaying ?installing? on some devices - just hit enter.
    • Open Termux and type:

    kali@kali:~$ termux-setup-storage
    kali@kali:~$ pkg install wget
    kali@kali:~$ wget -O install-nethunter-termux https://offs.ec/2MceZWr
    kali@kali:~$ chmod +x install-nethunter-termux
    kali@kali:~$ ./install-nethunter-termux

    You might have to reboot between wget and the chmod step to get it to work, and the google play app will still complain about nethunter everytime you reboot your phone!

  4. #4
    Join Date
    2023-Jan
    Posts
    1
    I am having same issue as original poster. I am on a pixel3 with grapheneos following the same directions. I disabled the native code debugging, same as original poster. It looks like the image never gets extracted. Anybpdy have any ideas?

Similar Threads

  1. Error install nethunter rootless
    By Sherry in forum Installing NetHunter
    Replies: 0
    Last Post: 2023-07-13, 05:59
  2. Replies: 0
    Last Post: 2023-06-18, 14:04
  3. Kali nethunter rootless download img file from termux CORRUPT
    By BdSM444 in forum NetHunter General Questions
    Replies: 0
    Last Post: 2022-05-08, 05:04
  4. Trying to Install Kali NetHunter Rootless on Nokia 7.1 Android Phone
    By richardstevenhack in forum Installing NetHunter
    Replies: 0
    Last Post: 2020-11-25, 09:43
  5. How to install snap on kali nethunter rootless
    By BPM in forum NetHunter General Questions
    Replies: 0
    Last Post: 2020-03-20, 13:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •