Results 1 to 5 of 5

Thread: Sound outputs through wrong audio device on 2022.2 Live AMD64

  1. #1
    Join Date
    2022-Aug
    Posts
    4

    Sound outputs through wrong audio device on 2022.2 Live AMD64

    Hi:

    I'm a relative newbie to Linux, but I'll do the work if you point me in the right direction.

    Asus M5AR97 v2.0 motherboard.
    Sound chip: Realtek 887 HD Audio

    I made a bootable USB flash drive and Kali boots fine. So far, most of what I tried works okay except for sound.
    Sound plays through my speakerphone, instead of through my onboard Realtek 887.

    I checked the Pulseaudio settings, and the Realtek does appear to be listed in there. However, when I try to configure sound settings to do playback through the sound card, it plays nothing. Needless to say, a speakerphone is not a good device to listen to video content. Pulseaudio is not what you'd call a user-friendly interface. Very confusing, IMO.

    Can anyone suggest how to fix this?


    Thanks

  2. #2
    Join Date
    2021-May
    Location
    UK
    Posts
    782

  3. #3
    Join Date
    2022-Aug
    Posts
    4
    Quote Originally Posted by Fred Sheehan View Post

    Unfortunately, that didn't work for me. Any other suggestions?

  4. #4
    Join Date
    2021-May
    Location
    UK
    Posts
    782
    sudo apt install pavucontrol

    That will give you a nice user friendly volume control that you can change settings easily, you need to change your output device to anaqlogue output type probably..

    Pulse audio defaults to HDA and sometimes this gives no sound

    another possible fix would be to tell Pulse audio what device to use for HDA sound..

    creating a file at /etc/modprobe.d/alsa-base.conf:

    options snd_hda_realtek index=1

    or

    options snd-hda-realtek model=generic

    if nothing else works..
    load up alsamixer (in a terminal type alsamixer hit return key) and use F6 to switch between soundcards to find the one with analogue output.

  5. #5
    Join Date
    2022-Aug
    Posts
    4
    Quote Originally Posted by Fred Sheehan View Post

    if nothing else works..
    load up alsamixer (in a terminal type alsamixer hit return key) and use F6 to switch between soundcards to find the one with analogue output.
    This, loading alsamixer and changing the setting worked. THANKS!

Similar Threads

  1. Kali sets audio volume to 74% whenever it switches a sound device
    By sncns in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2021-11-21, 20:50
  2. Replies: 1
    Last Post: 2019-12-03, 01:50
  3. Bluetooth Headphones (connected but don't appear in Sound outputs)
    By TomSmith in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-01-01, 16:09
  4. Replies: 1
    Last Post: 2014-03-19, 03:23

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •