Results 1 to 4 of 4

Thread: [Q] How to fully disable screen saver?

  1. #1
    Join Date
    2013-Mar
    Posts
    7

    [Q] How to fully disable screen saver?

    Hello,
    I'm runing Kali v1.0.1 amd64 installed on hdd.
    If it is meather, I installed KDE using:

    Code:
     apt-get install kde-full
    and fully uninstalled GNOME using:

    Code:
     apt-get remove --purge gnome*
    Now I want to fully disable screen saver, but don't know how. I tried several methods and comands taken from my friend Google, but everytime when I am watching a movie or flash video on net, screen goes to decrease brightnes after a few minutes. No, screen doesn't go full to sleep, but those litle brightnes decreases are anoying also.

    Does anybody know to tell me: How to fully disable screen saver, or auto brightnes decrease, or whatever.

    Sorry cause bad English, thanks in advance.

  2. #2
    Join Date
    2013-Mar
    Location
    Jasper, Alberta, Canada
    Posts
    7
    i just used this

    apt-get install x11-xserver-utils

    Now open up your ~/.xinitrc file (if you don't have one then create it) and enter this:

    xset s off # don't activate screensaver
    xset -dpms # disable DPMS (Energy Star) features.
    xset s noblank # don't blank the video device

    exec /etc/alternatives/x-session-manager # start lxde

    This file runs once every time X starts and should solve the problem. I copy and pasted it from my own .xinitrc and can confirm that my screen does not blank.
    Jean-Francois

  3. #3
    Join Date
    2013-Mar
    Posts
    7
    Thanks man. I was post question on two forums here on thisone, and here:

    http://www.kalilinux.net/community/t...een-saver.127/

    and get two diferent answers. I did both things, and now, my problem is solved. Thanks once again.

  4. #4
    Join Date
    2015-Aug
    Posts
    3
    Quote Originally Posted by Spyslab View Post
    i just used this

    apt-get install x11-xserver-utils

    Now open up your ~/.xinitrc file (if you don't have one then create it) and enter this:

    xset s off # don't activate screensaver
    xset -dpms # disable DPMS (Energy Star) features.
    xset s noblank # don't blank the video device

    exec /etc/alternatives/x-session-manager # start lxde

    This file runs once every time X starts and should solve the problem. I copy and pasted it from my own .xinitrc and can confirm that my screen does not blank.
    This didn't fix the issue for me. I get the following error after I save the file with text you provided:

    "x-session-manager[31792]: WARNING: Failed to acquire org.gnome.SessionManager"

    What would solve this?

Similar Threads

  1. Disable click-drag unlock screen on Kali 2.0
    By cmm in forum General Archive
    Replies: 2
    Last Post: 2017-03-08, 14:39
  2. Disable gnome slide screen
    By xelerated in forum How-To Archive
    Replies: 1
    Last Post: 2016-04-13, 09:09
  3. Dropdown Applications Menu not fully shown
    By 0xyy in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-02-01, 19:38
  4. Waiting for /dev to be fully populated
    By pmh in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-09-06, 00:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •