Results 1 to 11 of 11

Thread: Accessible speech installation failing at multiple stages (2022.2/.3/w33 in virtualbox)

  1. #1
    Join Date

    Accessible speech installation failing at multiple stages (2022.2/.3/w33 in virtualbox)

    Blind user attempting to install kali from iso downloaded from, kali-linux-2022.3-installer-amd64.iso, on virtualbox 6.1.34, host is Windows 10.
    Main request is for workaround to get gnome/orca running as soon as possible via command-line install/configuration.
    I am new to this, so pardon my ignorance. I need a lot of advice with lots of details, because I am not familiar with this process and with linux in general.
    When I reference output during the installation process, it is from speakup screen reader speech during installation, or from Windows 10 OCR output needed due to the screen reader not working at various stages, details below.

    Main problem:
    Options selected at Component Selection screen during installation does not then install any components, only minimal installation occurs.

    Other problems:
    1. Installation crashes (freezes) at seemingly random points during installation process, from first to last screens, speech stops, keyboard input is not accepted, must be aborted and restarted. Eventually the minimal installation succeeds, but the freezing sometimes occurs multiple times in a row with successive installation attempts.
    2. Twice gnome installed and loaded successfully, but then user account created during installation does not allow login.
    **3. Manual attempts to install gnome/orca fail, this one is due to my total ignorance, I'm sure. Could really use help with this one since it appears I will not be able to get gnome set up during the installation.

    Basic vm settings, including Processor/PAE enabled, followed instructions to disable 3d acceleration, enabled multiple network cards, multiple serial ports, otherwise basic setup, see attached.
    Note: I am fairly new to all this, so I don't know how to get virtualbox serial output to raw file which I would be glad to share if requested if someone can tell me how to get boot/other output to go to the raw file.

    Booted to iso, pressed 's', Enter, to start speech installation.
    If the installation does not freeze as described above and I make it to the Select Components screen, where it might also freeze, the default options are: 1 2 5 6 7.
    I want to install gnome for its accessibility, so I have tried typing many variations of the available options, including the following:
    13567 (no spaces)
    1 3 5 6 7 (with spaces)
    3 (no other options)
    (blank) (defaults selected, which should install xfce)

    Installation proceeds, but after completion and reboot, I am taken to the "This is a minimal installation" welcome message screen with user prompt at the command line. The resulting .vdi hd file is only 3.7gb, so I don't think gnome is hiding somewhere just waiting to be started, but I would be glad to be wrong about this, so that I could just run a command like 'gnome" to get it started with orca talking.

    There is no speech, so I blindly type sudo systemctl enable ssh to get ssh started, so that I can then open a command line via Windows, where my screen reader is working.

    **Since I am able to get to a command prompt, it is here I could use some detailed advice about how to install gnome manually. Here is what I have tried and failed with:

    Installed espeak, espeak-ng, speech-dispatcher, all of these work and can be used directly inside virtualbox, and speakup can also be enabled from its init.d file, so audio works.

    I then attempted to run task-gnome-desktop, and it seems to install gnome, but then orca does not start with win+alt+s at the login screen, so I am dead in the water, although I am told a command prompt can be started from the gnome login screen, but I have not been able to get that working, and even if I did, it would only be partially readable using constant Windows OCR'ing, which would be lame and probably not helpful. And I would not know what to do at that point. I have never been inside gnome with orca running, as I said I am new to this.

    Interesting note: All the above was done using 2022.3 (and also tried the w33 weekly build, but same problems as with 2022.3). However, I also tried 2022.2, and twice it allowed installation of gnome from the installation options screen, but after getting to the gnome login screen, where orca politely and helpfully starts, the user account does not allow login. This seems to be a known issue from way back several years, but again I am not able to employ workarounds at the login screen because I do not know how to open the command prompt from here, dead in the water again.

    After more full installation attempts using 2022.3 and getting the usual "minimal installation", I tried installing task-gnome-desktop brltty orca together using apt, but then before rebooting and losing access once again, I set AutomaticLoginEnable=true and similar setting for user to root in file /etc/gdm3/daemon.conf, and this results in booting to a lot of text output of various messages about login and network services starting, then ends with the text "Gnome Desktop Manager". But that's it, no gnome, no login screen, and not even a command prompt (as far as I can tell, no keyboard response at all).

    Three weeks later, still no gnome. Please help. If anyone at kali knows Samuel at the Debian Accessibility team, I'm sure he could help with this, but I am starting here.
    Attached Files Attached Files

  2. #2
    Join Date
    Hi there, sorry for a late reply..

    The latest 2022.3 version of Kali seems to drop to a basic terminal prompt after install no matter what I try.

    The earlier 2022.2 version however, that one will install, and is relatively painless to get working as expected.

    First off, when you get to the choice of what to install, if you choose anything that isn't already selected by default, it seems to have the same 'drop to basic terminal' bug as the later ISO.
    During my testing, I chose the install with speech supoort, but didn't try to choose anything other than defaults to install, (and that includes not installing Gnome at that point). All of the extra tools etc can be added in later from the Kali tweaks menu, so it is best to let it install with its defaults then later add Gnome and the extra tools.

    Once it is installed, the full Gnome package can be installed from a coomand line with;

    sudo apt-get install gnome-core kali-defaults kali-root-login desktop-base

    And, after a reboot, to set up orca you can launch the config editor with;

    orca --setup

    Hope this helps, if your still stuck, please post again!

  3. #3
    Join Date
    Fred, we are halfway there. I've had some trouble, but finally got logged into gnome (twice!) after running your apt command to get the basic setup, but I need help with two more important steps, including loggin in again:

    1. What is the trick to getting logged in at the gnome login screen? Because orca is not yet working (see #2), I am blindly fumbling around trying to put username and password where they need to go. So I need someone to power on his virtualbox vm, close his eyes, and without any audible assistance from orca (so you are blind and deaf simultaneously), please tell me what you do to get logged in. I try typing username/password immediately, username, tab, password, Enter, and this seemed to work once, but not today for some reason. I would need your exact keystrokes.

    Here are some details:
    The gnome login screen seems very inconsistent. Sometimes I can ocr the screen and see that it says "surname" (or maybe sername if the ocr is behaving normally badly) and "kali", presumably the username field and the computer name. But this text has only appeared a couple of times, now it never does for whatever reason, so this is why I am needing to know exactly what the normal sequence of keypresses is so that I can blindly/deafly log in, not knowing at all where the cursor is. I'm sure other new blind users would very much appreciate this information.

    I give the vm plenty of time to load, several minutes, but most of the time (like right now), I cannot log in at all, and of course ssh is dead until after login, so I also am dead until someone can tell me how to get logged in consistently.

    2. Orca. I was able one time to install orca over ssh after one of my two successful gnome logins, sudo apt install orca. Looked like it installed all the necessary components, espeak-ng, speech-dispatcher, pulseaudio, etc. But during that session I was not able to get orca started, and that was one instance after which rebooting showed no text at all at the login screen, so I thought I had broken something and it was not booting, but now I think I simply need to do some kind of trick at the gnome login screen to get logged in, then maybe I can discover how to start orca. Could anyone confirm I am installing orca correctly? After I am able to log in consistently, I will be able to experiment more, but that is all I've been able to try so far. Any additional info on exact steps for getting orca running within gnome after login would also be great.

    Thanks again.

  4. #4
    Join Date
    Using the Gnome desktop, To toggle Orca on and off , press Super + Alt + S buttons together, that 'should' start orca at the log in screen.

  5. #5
    Join Date
    If that doesn't work, then its likely related to an SE Linux issue, a fix found on the Fedora forum, (Fedora use the Gnome desktop environment by default)

    in a terminal;

    sudo tee /tmp/custom.te << EOF
    module custom 1.0;
    require {
    class sock_file write;
    class unix_stream_socket connectto;
    type tmp_t;
    type unconfined_service_t;
    type xdm_t;
    allow xdm_t tmp_t:sock_file write;
    allow xdm_t unconfined_service_t:unix_stream_socket connectto;
    sudo checkmodule -M -m -o /tmp/custom.mod /tmp/custom.te
    sudo semodule_package -o /tmp/custom.pp -m /tmp/custom.mod
    sudo semanage module -r custom
    sudo semanage module -a /tmp/custom.pp

    and that should allow Orca to work as soon as the system boots.

    I shall install Kali in virtual box and test for how to log in from GDM directly without any output from Orca to guide you, anser for that later today!

  6. #6
    Join Date
    Sorry, I should have mentioned that I blew away the orca installation by reverting to a snapshot because I thought I broke the entire system, so orca is not currently installed, but I promise I tried the win+alt+s trick about 773 times, no luck. Needing tips on installing it correctly if sudo apt install orca is not the right/only command. Anything else I should be doing to get it installed correctly?

  7. #7
    Join Date
    Fred, my dear man, long live the Queen, but I promise I will break it if I try your Fedora/tee trick. Kali uses SE Linux? I thought that was an entirely separate thing? I would bet the crown jewels we could get everything working without resorting to selinux hacks. First things first, though, and that is getting logged in consistently. Today the moon is in a different phase, apparently, because I have been able to log in about four times in the last two hours, but just as many failures. The failures are because of the "blank" screen (Windows 10 ocr indicates no text appears on the login screen) that appears after boot instead of the text "Username, KALI" window where I can (sometimes) successfully log in, although I still need help knowing the exact tab sequence to get logged in consistently. If Windows 10 ocr does not show any text, which occurs probably 80% of the time, I am completely stuck, cannot log in. What is the trick for getting the login screen to show the username field to allow login?
    So if it boots to a blank screen (blank according to windows 10 ocr text output telling me I am at the login screen), surely there is a trick to get the username field to appear so that I can log in even if that dreaded blank screen appears?

    I know how much you sighted people like pictures, so I've taken screenshots of both the "normal" login screen showing the username field, and the "blank" login screen which has never allowed me to login, even when I bang on the keyboard with both fists. If there is a way to send the screenshots to you privately, please let me know.

    As mentioned, about eighty percent of the time after booting the vm, I get the blank screen, and I can never figure out how to make the login screen appear, so I have to do a vboxmanage poweroff, but today the ratio was about even for whatever reason so I was able to log in a few times, now I cannot, very sad. Also, I have again tried to enable automatic login to bypass all this insane frustration of just getting logged in, but now that also is not working (it worked last week with a long-ago snapshot). Edited /etc/gdm3/daemon.conf to enable root and the normal user to log in, but neither worked. That is a poor workaround though, so knowing how to get logged in consistently is the real goal.

    All the documentation I've found so far around the web assumes the blind guy user is somehow an expert with all of this already and leaves out all the details to get going.

    Thanks again for all your help.

  8. #8
    Join Date
    Hi there, sorry for a delayed reply.

    I have tried several installs with Kali and anytime that you try and use install with speech option, it always ends up after its installed, that you reboot to a command prompt in a minimal install, which doesn?t even 'speak' to you at that point, so is pretty poor, and I have filed this as a bug, hopefully it will be looked at by the devs;

    Having watched the install process during the graphic install, you can choose to disable the XFCE desktop and select only Gnome, and this will proceed with the install and set up the Gnome GDM greeter properly, similarly if you choose multiple desktops to install, it will asjk which greeter to set up for you.

    In contrast, during a speech assisted install, when you get to software selection, you cannot unselect XFCE desktop, and even if you choose to install Gnome as well, it doesn't actually have that step where it asks you which greeter to configure, so no matter what you do, it ends up at that minimal install command prompt upon install.

    Now, I know we are past that in your case, so...

    Once the Gnome desktop log in screen appears (it won't speak to you on the log in screen which again is I think a bug), it will have already highlighted your username (presuming your the only user of course)
    So press return key once to choose username and then it will give the password section input, type in your password, and press return again.

    This will log you in to your desktop, where a screen reader should be working if previously set up.

    I did notice that when resuming from sleep, it would tell me it was 'blank' but that was actually the log in screen with my name already selected, and I just had to type my password in and hit return at that point.

    I hope this is helpful lorange01
    Last edited by Fred Sheehan; 2022-10-14 at 07:58.

  9. #9
    Join Date
    I had an email sent me, so It looks like the Devs are now at least aware of this, and will be looking into the speech install problem, however I've been told its likely to be after the next 2022.4 release now before it can be fixed.

    Lets hope that 2023.1 release will be working as expected!

  10. #10
    Join Date
    Hello, the issue should be fixed in the weekly image (2023-W05). I just tested the installer image and it worked, there was speech synthesis during installation, and also in the XFCE greeter (aka. lightdm), and also after logging in XFCE. Please give it a try:

    Feel free to re-open if needed (if you post on this forum, I might miss your answer, I don't know if I will receive a notification).

    Thanks for your patience!

  11. #11
    Join Date
    The following issue has been RESOLVED.
    ================================================== ====================
    ================================================== ====================
    Reported By: Fred_Sheehan
    Assigned To: arnaudr
    ================================================== ====================
    Project: Kali Linux
    Issue ID: 7999
    Category: General Bug
    Reproducibility: always
    Severity: minor
    Priority: normal
    Status: resolved
    Resolution: fixed
    Fixed in Version:
    ================================================== ====================
    Date Submitted: 2022-10-10 23:28 UTC
    Last Modified: 2023-01-31 08:19 UTC
    ================================================== ====================
    Summary: Anytime installation using the speech selection, no
    matter what options chosen always end at a minimum base install text console
    On the Kali forum several users have asked how to get Orca working on their Kali
    install, and whilst that is possible, it doesn't actually 'speak' the username
    field on the log in screen even when Orca is workinbg after the log in has
    Without the screen reader features working on that screen, they then cannot log
    in to their account, making the now working install, not accessable from a

    Steps to Reproduce:
    From the Kali installer screen, choose the speech accesability option for
    install, the install process speech works, but no matter which options are
    chosen at the software selection screen, after it has installed and wants to
    reboot, the user is left at a basic install prompt without the ability to log in
    to any kind of desktop.

    Additional Information:
    The only way that works properly is to install Kali without speech option and
    only after its booted to to a desktop, to then install and configure any missing
    software. As a sighted user this is clearly no problem for me, but is not
    apropriate for users who need the screen reader functions.

    I have tried several versions of Kali including some earlier releases, and all
    seem to show the same behaviour.
    ================================================== ====================

    (0017108) arnaudr (manager) - 2022-11-30 06:00
    Hey, just to let you know that we're working on that, there are different things
    broken with speech synthesis install at the moment, as you noticed.
    Unfortunately it won't be fixed in time for the upcoming 2022.4 release, but I
    hope we'll have a functional weekly image shortly afterward. I'll ping again on
    this channel. Thanks for your patience!

    (0017443) arnaudr (manager) - 2023-01-31 08:18
    Hello, the issue should be fixed in the weekly image (2023-W05). I just tested
    the installer image and it worked, there was speech synthesis during
    installation, and also in the XFCE greeter (aka. lightdm), and also after
    logging in XFCE. Please give it a try:

    Feel free to re-open this issue if needed, if ever there's more things to fix.

    Thanks for your patience!

    Issue History
    Date Modified Username Field Change
    ================================================== ====================
    2022-10-10 23:28 Fred_Sheehan New Issue
    2022-11-30 06:00 arnaudr Note Added: 0017108
    2023-01-31 08:18 arnaudr Note Added: 0017443
    2023-01-31 08:19 arnaudr Assigned To => arnaudr
    2023-01-31 08:19 arnaudr Status new => resolved
    2023-01-31 08:19 arnaudr Resolution open => fixed
    ================================================== ====================

Similar Threads

  1. Error with installing Virtualbox on Kali Linux 2022.1
    By range in forum General Archive
    Replies: 0
    Last Post: 2022-03-25, 18:54
  2. Problem with installation of kali 2020.2 with speech
    By nsoft in forum Installing Archive
    Replies: 0
    Last Post: 2020-05-16, 19:44
  3. Replies: 4
    Last Post: 2020-01-13, 08:40
  4. VirtualBox - Guest Additions 5.2.18 - Failing to install
    By Chaplin in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2018-09-19, 06:55
  5. Installation failing in VirtualBox
    By koganmj in forum Installing Archive
    Replies: 6
    Last Post: 2014-12-27, 19:21

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts