Results 1 to 5 of 5

Thread: Can not run upgrade or install some software

  1. #1
    Join Date
    2022-Aug
    Posts
    3

    Can not run upgrade or install some software

    I am very new to Lynix and have googled around but can not find a answer.

    This happens on two different computers.
    /usr/bin/apt-get
    Hit:1 https://repo.nordvpn.com/deb/nordvpn/debian stable InRelease
    Hit:2 http://kali.download/kali kali-rolling InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    apt-transport-https is already the newest version (2.5.2).
    0 upgraded, 0 newly installed, 0 to remove and 376 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up initramfs-tools (0.142) ...
    update-initramfs: deferring update (trigger activated)
    Processing triggers for initramfs-tools (0.142) ...
    update-initramfs: Generating /boot/initrd.img-5.18.0-kali5-amd64
    raspi-firmware: missing /boot/firmware, did you forget to mount it?
    run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
    dpkg: error processing package initramfs-tools (--configure):
    installed initramfs-tools package post-installation script subprocess returned error exit status 1
    Errors were encountered while processing:
    initramfs-tools
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    from my reading I think it has something to do with raspi being removed in the latest version. But I can not seem to figure out how to remove it form the list if tha is what is needed. Any help would be greatly appreciated.

    Thank you for you time.

  2. #2
    Join Date
    2021-May
    Location
    UK
    Posts
    507
    Can't remember exactly where I read this now, apparently just purging it should do it;

    sudo apt purge --autoremove raspi-firmware

  3. #3
    Join Date
    2022-Aug
    Posts
    3
    Good news I was able to resolve this by removing the module. did apt-get remove raspi-firmware.

  4. #4
    Join Date
    2022-Aug
    Posts
    3

    Thank you

    Quote Originally Posted by Fred Sheehan View Post
    Can't remember exactly where I read this now, apparently just purging it should do it;

    sudo apt purge --autoremove raspi-firmware


    thank you for the replay. I was able to fix this with the statement you provided.

  5. #5
    Join Date
    2021-Jun
    Location
    The Land of the Dead
    Posts
    39
    Quote Originally Posted by JohnBailey View Post
    I am very new to Lynix and have googled around but can not find a answer.
    Next time use the correct spelling for your keywords.
    Last edited by Trihexagonal; 2022-09-23 at 06:14.

Similar Threads

  1. I can't install any other software Why?
    By moulisk37 in forum General Archive
    Replies: 0
    Last Post: 2020-12-23, 10:05
  2. installation step failled: software and install software
    By justaguy in forum Installing Archive
    Replies: 0
    Last Post: 2020-12-14, 17:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •