Results 1 to 8 of 8

Thread: Coding colors from text editor are gone

  1. #1
    Join Date
    2022-Oct
    Posts
    5

    Coding colors from text editor are gone

    issue.jpgdefault.jpg

    Color coding from default text editor is gone grey. I dont know why. Changing theme from settings has no effect on this.
    I tried to reset desktop environment with this command but it did not bring back the colors.
    Code:
    rm -rf ~/.config/xfce4/ && sudo reboot
    copying theme files from another default install has not worked. How do i reset this back to when i installed the vmware version settings?
    to clarify, grey img is what i have now.

    Im running kali latest vmware version.

  2. #2
    Join Date
    2021-May
    Location
    UK
    Posts
    507

  3. #3
    Join Date
    2022-Oct
    Posts
    5
    Solution above hasn?t helped as I have already copied over theme files from another install. Issue stays.

  4. #4
    Join Date
    2021-May
    Location
    UK
    Posts
    507
    Themes in mousepad are picked up through gtk settings;

    https://draculatheme.com/mousepad

  5. #5
    Join Date
    2022-Oct
    Posts
    5
    Quote Originally Posted by Fred Sheehan View Post
    Themes in mousepad are picked up through gtk settings;

    https://draculatheme.com/mousepad
    I installed the above theme for GTK and for mousepad. It appears in theme switching menu but the issue remains. is there a chance it may not be a theme issue?


  6. #6
    Join Date
    2021-May
    Location
    UK
    Posts
    507
    Or its being overwritten, I'm presuming you have fully installed it, i.e created the folder etc in HOME directory and tried changing gtk3 to gtk4 etc as per the link?

    Have you changed your Desktop environment, if using XFCE mousepad should foillow appearence choice in settings..

    There are a few other places that can config files can override user settings, the Arch Wiki is always a good start for weird Linux problems;

    https://wiki.archlinux.org/title/GTK#Themes

  7. #7
    Join Date
    2022-Oct
    Posts
    5

    I installed as per instructions on the dracula theme website /home/kali/.local/share/gtksourceview-4/styles/dracula.xml/home/kali/mousepad/ {git files are installed here}
    Quote Originally Posted by Fred Sheehan View Post
    Have you changed your Desktop environment, if using XFCE mousepad should foillow appearence choice in settings..
    No, the default install and settings are unchanged. Im not sure about being overwritten. This i havent considered earlier. I'd look into this. Thank you for referral links though. I liked it so much i even installed Dracula theme for Notepad++ for windows.

  8. #8
    Join Date
    2022-Oct
    Posts
    5
    Okay. you got me thinking on config settings so i copied /home/kali/.config folder from a new install to my vmware, then i reset settings using dconf from here.https://ostechnix.com/backup-and-res...20Linux%3AMost of my colors are now back with the exception of *.md file extension (and php which still remains grey). I still cant figure out where to get .md colors back but now i can code in color. Thank you so much Fred.

Similar Threads

  1. Terminal text colors.
    By kemposs in forum General Archive
    Replies: 0
    Last Post: 2020-05-25, 07:40
  2. default text editor
    By slaxd in forum General Archive
    Replies: 2
    Last Post: 2017-07-23, 09:41
  3. Text editor VI NANO PICO
    By sidious in forum NetHunter General Questions
    Replies: 0
    Last Post: 2016-12-28, 14:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •