Results 1 to 14 of 14

Thread: Configuring xorg.conf for nvidia drivers

  1. #1
    Join Date
    2013-Mar
    Posts
    30

    Question Configuring xorg.conf for nvidia drivers

    Hi, I would like to use my GPU to power Pyrit but my Nvidia GPU isn't detected.

    Here is what I've tried:
    Code:
    # apt-get update
    # apt-get install linux-headers-$(uname -r)
    # apt-get install nvidia-kernel-dkms
    reboot - the install said Nouveau would conflict but would be corrected by a restart.
    # apt-get install nvidia-xconfig
    # nvidia-xconfig
    reboot
    After the nvidia-xconfig I reboot and then my X doesn't start again.

    I've also installed via the .run from nvidia, but the nvidia drivers wern't used and creating the XOrg.conf causes X to still not boot.

    Can anyone help me install the nvidia drivers on my persistence USB so that I can use my GPU with Pyrit please?

    EDIT: It seems the install isn't the problem. The problem is with the /etc/X11/XOrg.conf. It seems like creating one prevents X from booting.
    I've tried the Nvidia-xconfig and created a new .conf (as http://wiki.debian.org/NvidiaGraphic...e_an_xorg.conf says to ) containing:
    Code:
    Section "Device"
        Identifier  "Video Card"
        Driver              "nvidia"
    EndSection
    I don't know what else to do to make my Nvidia drivers work.

    UPDATE:
    I am running Kali amd64 v1.0.2 usb persistent with a nvidia optimus card (dedicated nvidia/Integrated intel).
    Tried bumblebee, all versions of nvidia's .debs, nvidia-kernel-dkms, samiux's blog post, nvidia's .run. Also tried running the kernel with the nomodeset option.

    I am still unable to get nvidia drivers working. Still looking for a solution.
    Last edited by xNotta; 2013-04-03 at 02:57.

  2. #2
    Join Date
    2013-Mar
    Posts
    31
    Samiux created a thread with the right way to apt-install the nvidia drivers. He also has it up on his blogspot at "http://samiux.blogspot.com/". Before you install you should make sure you have a file called "nvidia-installer-disable-nouveau.conf" inside of [/etc/modprobe.d/]. If it's not there, create it and paste inside...
    blacklist nouveau
    options nouveau modeset=0
    Then reboot, open a terminal and type [/etc/init.d/gdm3 stop], then paste the commands from Samiux (a good way to do that is paste the commands before you reboot but DON'T hit enter, then after you've done the [gdm3 stop] press the up arrow on kb and hit enter)
    After it's installed reboot right away. When you see the blinking curser do Ctrl-Alt-F3. Do a cmd prompt login. Do [nvidia-xconfig]. Reboot
    That should get it working.

  3. #3
    Join Date
    2013-Mar
    Posts
    30
    Quote Originally Posted by kpoeticg View Post
    Samiux created a thread with the right way to apt-install the nvidia drivers. He also has it up on his blogspot at "http://samiux.blogspot.com/". Before you install you should make sure you have a file called "nvidia-installer-disable-nouveau.conf" inside of [/etc/modprobe.d/]. If it's not there, create it and paste inside...
    blacklist nouveau
    options nouveau modeset=0
    Then reboot, open a terminal and type [/etc/init.d/gdm3 stop], then paste the commands from Samiux (a good way to do that is paste the commands before you reboot but DON'T hit enter, then after you've done the [gdm3 stop] press the up arrow on kb and hit enter)
    After it's installed reboot right away. When you see the blinking curser do Ctrl-Alt-F3. Do a cmd prompt login. Do [nvidia-xconfig]. Reboot
    That should get it working.
    Thanks for the info.
    Unfortunately Samiux appears to have deleted the kali specific blog post due to him being banned or something.
    Archive.org doesn't have a cached version.
    http://samiux.blogspot.com/2013/03/h...ali-linux.html

    Going to try to wing it with the other stuff you said.

    Anyone know where else I can find those instructions?

  4. #4
    Join Date
    2013-Mar
    Posts
    27
    Quote Originally Posted by kpoeticg View Post
    Samiux created a thread with the right way to apt-install the nvidia drivers. He also has it up on his blogspot at "http://samiux.blogspot.com/".
    He is an angry user now and deleted his blog entry.Could you write the commands here?

  5. #5
    Join Date
    2013-Mar
    Posts
    30
    Quote Originally Posted by kpoeticg View Post
    Samiux created a thread with the right way to apt-install the nvidia drivers. He also has it up on his blogspot at "http://samiux.blogspot.com/". Before you install you should make sure you have a file called "nvidia-installer-disable-nouveau.conf" inside of [/etc/modprobe.d/]. If it's not there, create it and paste inside...
    blacklist nouveau
    options nouveau modeset=0
    Then reboot, open a terminal and type [/etc/init.d/gdm3 stop], then paste the commands from Samiux (a good way to do that is paste the commands before you reboot but DON'T hit enter, then after you've done the [gdm3 stop] press the up arrow on kb and hit enter)
    After it's installed reboot right away. When you see the blinking curser do Ctrl-Alt-F3. Do a cmd prompt login. Do [nvidia-xconfig]. Reboot
    That should get it working.
    Thanks for the reply.
    I am not sure what is going on, but all of my post need mod approval and I am not sure if they just haven't got to it today or if they deleted my post.

    The tutorial on his blog was deleted by him.
    Do you know anywhere else I can find the commands to install the drivers?
    Last edited by xNotta; 2013-04-03 at 02:45.

  6. #6
    Join Date
    2013-Apr
    Location
    Midwest, USA
    Posts
    1
    If you have a Lenovo with the Optimus card, it may be a lost cause. I finally gave up after trying the same things. I couldn't get any driver or combination of drivers to work. i don't have the thread anymore, but I tried Samiux's steps on my Lenovo 530 and it didn't work.

  7. #7
    Join Date
    2013-Mar
    Posts
    30
    Samiux's Blog is back up:
    http://samiux.blogspot.com/2013/03/h...ali-linux.html

    Code:
    Installation of nVidia Display Card Driver
    
    apt-get update
    
    apt-get install nvidia-detect nvidia-libopencl1 nvidia-opencl-common nvidia-support nvidia-opencl-icd nvidia-visual-profiler nvidia-glx nvidia-installer-cleanup nvidia-kernel-common nvidia-smi nvidia-alternative nvidia-opencl-dev libglx-nvidia-alternatives nvidia-kernel-dkms nvidia-cuda-toolkit nvidia-vdpau-driver nvidia-xconfig glx-alternative-nvidia libgl1-nvidia-alternatives nvidia-settings libgl1-nvidia-glx xserver-xorg-video-nvidia libcublas4 libcudart4 libcufft4 libnpp4 libnvidia-compiler libcuda1 libcuinj4 libnvidia-ml1 libxvmcnvidia1 libcusparse4 libcurand4 python-pycuda-doc python-pycuda-headers python-pycuda nvidia-cuda-doc nvidia-cuda-gdb
    
    Then, reboot your box. Although the version of the driver is quite old but it is workable.
    Didn't work for me. I do have an optimus card.

    If anyone else has any other ideas, please post them.

  8. #8
    Join Date
    2013-Mar
    Posts
    4
    It appears Nvidia has just released a new beta driver addressing this Optimus issue.

    News article: http://www.phoronix.com/scan.php?pag...tem&px=MTM0NzE

    Nvidia Devtalk Forum post w/ download link at the bottom: https://devtalk.nvidia.com/default/t...-319-12-beta-/

    Hopefully this helps

  9. #9
    Join Date
    2013-Mar
    Posts
    30
    Quote Originally Posted by Renek View Post
    It appears Nvidia has just released a new beta driver addressing this Optimus issue.

    News article: http://www.phoronix.com/scan.php?pag...tem&px=MTM0NzE

    Nvidia Devtalk Forum post w/ download link at the bottom: https://devtalk.nvidia.com/default/t...-319-12-beta-/

    Hopefully this helps
    Thanks for the tip about the new beta drivers.

    I got them to install using the .run, but pyrit still isn't using my gpu.

    When I did the nvidia-xconfig, it still goes to the blank screen with the blinking line in the corrner.

    Im going to mess around with it some more, but if anyone knows what I am doing wrong; please post.

  10. #10
    Join Date
    2013-Mar
    Posts
    5
    up i have the same problem with nvidia geforce gt 540m on acer laptop

  11. #11
    Join Date
    2013-Apr
    Posts
    5
    I'm using 64bit version of Kali, and running laptop with optimus based geforce 540m.
    I was able to configure nvidia drivers (with optimus switching) using this tutorial :http://www.backtrack-linux.org/forum...ad.php?t=48331

    (See post #1 and #6)

  12. #12
    Join Date
    2013-Mar
    Posts
    30
    Quote Originally Posted by avaterera View Post
    I'm using 64bit version of Kali, and running laptop with optimus based geforce 540m.
    I was able to configure nvidia drivers (with optimus switching) using this tutorial :http://www.backtrack-linux.org/forum...ad.php?t=48331

    (See post #1 and #6)
    Followed all of post #1 but it didn't work for me, pyrit still is only benchmarking my CPUs cores.

    I have a GTX660M running 64bit Kali USB Persistence.
    Last edited by xNotta; 2013-04-17 at 00:30.

  13. #13
    Join Date
    2013-Apr
    Posts
    4
    I'm not sure if this will work for all of you, but last time I had trouble installing Nvidia drivers I finally gave up and thought, "Hey why not check out Nvidia's site?" Best decision, EVER.

    Uninstall the Nvidia package from the repos and download the .run file for your specific driver from Nvidia's site, run the file with ./NVIDIA-Driver-blahblahblahversionsandthings.run (make sure it's executable first by changing it's permissions with chmod +x) and I almost would be willing to bet that this should solve your problems. This will also run nvidia-xconfig for you and it will make sure if you're running a 64 bit machine that you also have 32 bit libraries installed in case you might need them for anything. Trust a brother on this one. Install from Nvidia, startx and let me know if your troubles are over

  14. #14
    Join Date
    2013-Jul
    Posts
    3
    Sorry that's the first thing i did and it didn't work... Everytime i install nvidia drivers i get blank screen at start up ( although gdm3 works!)
    In fact when you type "gdm3 start" it fails because the service is already started, i figured that by doing gdm3 stop and then gdm3 start.
    Now my laptop is acer, i have Nvidia GT 730M and Intel HD graphic cards and i really need to install nvidia drivers on kali and i've been stuck on this for 5 days now. So if anyone found a solution, please help!!!
    Thanks

Similar Threads

  1. Replies: 0
    Last Post: 2017-01-15, 10:39
  2. Replies: 1
    Last Post: 2016-09-24, 07:25
  3. Nvidia xorg.conf - TTY1 cursor cannot Startx
    By Sowexly in forum General Archive
    Replies: 0
    Last Post: 2016-09-12, 15:49
  4. Configuring dhcpd.conf with two LAN-cards?
    By Pelle in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-06-08, 09:55
  5. Replies: 1
    Last Post: 2013-04-03, 20:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •