Results 1 to 2 of 2

Thread: Cannot ssh into raspberry pi zero W

  1. #1
    Join Date

    Cannot ssh into raspberry pi zero W

    Hi, I was trying to run raspberry pi zero W on kali Linux (, Raspberry Pi Zero W) via ssh.
    As usual, I created wpa_supplicant.conf and filled out the details, and created an empty file named "ssh" to enable ssh.
    raspberry pi zero W connected to WiFi and, after finding out his address using Avast antivirus, tried to ssh into it Code:

    ssh kali@(ip_address)
    As usual, I needed a password to ssh into it. I tried the password "kali" but I got an error like this: Code:

    which I think is about the wrong password. What are your thoughts?

  2. #2
    Join Date
    To SSH into your Raspberry Pi Zero W running Kali Linux, you can follow these steps:

    1. Ensure that your Raspberry Pi Zero W is connected to the same Wi-Fi network as your computer.
    2. Find the IP address of your Raspberry Pi Zero W on the network. You mentioned using Avast antivirus to discover the IP address, so you can use that information.
    3. Open a terminal or command prompt on your computer.
    4. Use the SSH command to connect to your Raspberry Pi. Replace <IP_ADDRESS> with the actual IP address of your Pi. The default username is "root" and the default password is "toor" for Kali Linux.

      ssh root@<IP_ADDRESS>
      1. If this is your first time connecting to the Raspberry Pi, you may see a security warning asking if you want to continue connecting. Type "yes" to proceed.
      2. Enter the password when prompted (default password: "toor") and press Enter.

      After completing these steps, you should be connected to your Raspberry Pi Zero W via SSH, and you can interact with it through the command line remotely.
    Last edited by saith2562; 2023-08-16 at 08:30.

Similar Threads

  1. Raspberry Pi won't boot up anymore (Kali Raspberry)
    By Quentium in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2019-02-17, 21:55
  2. Raspberry pi 3 B+ SSH
    By debault in forum ARM Archive
    Replies: 3
    Last Post: 2018-10-30, 19:02
  3. Raspberry Pi 2 B v1.2
    By redfox in forum ARM Archive
    Replies: 2
    Last Post: 2017-01-14, 02:56

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts