Results 1 to 5 of 5

Thread: tried to install 64amd to my external hdd and got grub error. anybody know how to fix

  1. #1
    Join Date
    2013-Mar
    Posts
    12

    tried to install 64amd to my external hdd and got grub error. anybody know how to fix

    GRUB loading.
    Welcome to GRUB!

    error;invalid extent
    Entering rescue mode...
    grub rescue>


    when i type in the command "ls" at grub rescue> i get this (hd0) (hd0,msdos1)

    i tried this as well

    grub rescue> set prefix="(hd0,msdos1)/grub" and it didnt work, i'm not too sure what to do. any help would be nice!

  2. #2
    Join Date
    2013-Mar
    Posts
    269
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  3. #3
    Join Date
    2013-Mar
    Posts
    354
    if you get the grub prompt, it means grub never found the grub.cfg. So it does not know what partition to boot from. It finds nothing.

    Did the grub installed in the external HDD?...

  4. #4
    Join Date
    2013-Jun
    Posts
    3
    I have had the same problem trying to install Kali Linux for Amd64 to an enternal HDD. The drive is a 350GB Iomega eGo drive and was mounted as sdc. I installed to the first partition of the drive sdc1 and formatted it as ext4 and set the mount point to /. I selected the MBR to be loaded onto sdc. The installation went without a problem but on rebooting I got the same Entering rescue mode...
    grub rescue>
    as the OP above.

    I also used Xubuntu with the external HDD mounted and entered
    sudo update-grub
    sudo grub-install /dev/sdc

    On rebooting I selected the Kali option and got another grub error.
    file /boot/vmlinuz-3.7-trunk-amd64 not found
    you need to load the kernel first


    The file does exist on the external HDD
    Have I done something wrong? Is it a bug? Is there any way I can use the external HDD with Kali installed on it?

    I only have Xubuntu 13.04 on my main drive - Windows or any flavour is banished from my house!!

    TIA

    Alan
    Last edited by Polymorph; 2013-06-21 at 13:50. Reason: mis-spelling

  5. #5
    Join Date
    2013-Jun
    Posts
    3
    Initially I used the whole of the 300GB external HDD - apart from a 2GB swap partition - and got the grub rescue error. I repartitioned the drive and am now using a 30GB partition to install Kali to. This worked perfectly!! Strange.

    I seem to remember from some other forum several years ago the suggestion that grub cannot handle very large partitions. Can anyone explain why this is so.

    Alan

Similar Threads

  1. Installing on external hard disk grub issue
    By Blackshield1 in forum Installing Archive
    Replies: 0
    Last Post: 2015-07-10, 21:08
  2. Installing GRUB to external HDD
    By Flaw in forum Installing Archive
    Replies: 0
    Last Post: 2013-09-16, 01:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •