Results 1 to 2 of 2

Thread: SQLMAP COMMAND "y" not found after update

  1. #1
    Join Date
    2013-Mar
    Location
    In AnonWorld
    Posts
    38

    SQLMAP COMMAND "y" not found after update

    RESOLVED SOME WEBSITES BLOCKING SQLMAP THATS WHY IF YOU TRY DIFFERENT WEBSITES IT WORKS FINE
    MY EXCUSE & SORRY FOR REPOSTING

    Hi,
    Facing this problems many after upgrading times previous times i reinstalled kali
    but now i want to have the fix & solution
    i just typed :
    root@Gr4nDT3R0R:~# apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages will be upgraded:
    bind9-host dnsutils host icedtea-6-jre-cacao icedtea-6-jre-jamvm libbind9-80
    libdns88 libisc84 libisccc80 libisccfg82 liblwres80 metasploit
    metasploit-framework openjdk-6-jdk openjdk-6-jre openjdk-6-jre-headless
    openjdk-6-jre-lib set sqlmap
    19 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 97.9 MB/236 MB of archives.
    After this operation, 14.9 MB disk space will be freed.
    Do you want to continue [Y/n]? y
    Get:1 http://repo.kali.org/kali/ kali-bleeding-edge/main set all 5.1+0~git1375076559.2584c1-1 [45.1 MB]
    Get:2 http://security.kali.org/kali-security/ kali/updates/main openjdk-6-jdk amd64 6b27-1.12.6-1~deb7u1 [11.0 MB]
    Get:3 http://repo.kali.org/kali/ kali-bleeding-edge/main sqlmap all 1.0+git20130217+0~git1374990203.b921ff-1 [7,062 kB]
    Get:4 http://security.kali.org/kali-security/ kali/updates/main openjdk-6-jre amd64 6b27-1.12.6-1~deb7u1 [238 kB]
    Get:5 http://security.kali.org/kali-security/ kali/updates/main icedtea-6-jre-jamvm amd64 6b27-1.12.6-1~deb7u1 [599 kB]
    Get:6 http://security.kali.org/kali-security/ kali/updates/main icedtea-6-jre-cacao amd64 6b27-1.12.6-1~deb7u1 [807 kB]
    Get:7 http://security.kali.org/kali-security/ kali/updates/main openjdk-6-jre-headless amd64 6b27-1.12.6-1~deb7u1 [25.5 MB]
    Get:8 http://security.kali.org/kali-security/ kali/updates/main openjdk-6-jre-lib all 6b27-1.12.6-1~deb7u1 [6,143 kB]
    Get:9 http://security.kali.org/kali-security/ kali/updates/main dnsutils amd64 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [166 kB]
    Get:10 http://security.kali.org/kali-security/ kali/updates/main bind9-host amd64 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [73.4 kB]
    Get:11 http://security.kali.org/kali-security/ kali/updates/main libisc84 amd64 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [182 kB]
    Get:12 http://security.kali.org/kali-security/ kali/updates/main libdns88 amd64 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [750 kB]
    Get:13 http://security.kali.org/kali-security/ kali/updates/main libisccc80 amd64 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [35.9 kB]
    Get:14 http://security.kali.org/kali-security/ kali/updates/main libisccfg82 amd64 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [62.8 kB]
    Get:15 http://security.kali.org/kali-security/ kali/updates/main liblwres80 amd64 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [55.2 kB]
    Get:16 http://security.kali.org/kali-security/ kali/updates/main host all 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [20.6 kB]
    Get:17 http://security.kali.org/kali-security/ kali/updates/main libbind9-80 amd64 1:9.8.4.dfsg.P1-6+nmu2+deb7u1 [42.2 kB]
    Fetched 97.9 MB in 1min 59s (818 kB/s)
    Preparing to replace metasploit 4.7.0-2013071702-1kali0 (using .../metasploit_4.7.0-2013072401-1kali0_amd64.deb) ...
    [ ok ] Stopping Metasploit worker: worker.
    [ ok ] Stopping Metasploit web server: thin.
    [ ok ] Stopping Metasploit rpc server: prosvc.
    Leaving 'diversion of /usr/bin/msfbinscan to /usr/bin/msfbinscan.framework by metasploit'
    Unpacking replacement metasploit ...
    Preparing to replace set 5.1+0~git1374558154.fb8205-1 (using .../set_5.1+0~git1375076559.2584c1-1_all.deb) ...
    Unpacking replacement set ...
    Preparing to replace sqlmap 1.0+git20130217+0~git1374299029.dbb0d7-1 (using .../sqlmap_1.0+git20130217+0~git1374990203.b921ff-1_all.deb) ...
    Unpacking replacement sqlmap ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for gnome-menus ...
    Processing triggers for hicolor-icon-theme ...
    Processing triggers for man-db ...
    Setting up libisc84 (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up libdns88 (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up libisccc80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up libisccfg82 (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up libbind9-80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up liblwres80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up bind9-host (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up host (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up dnsutils (1:9.8.4.dfsg.P1-6+nmu2+deb7u1) ...
    Setting up metasploit-framework (4.7.0-2013072401-1kali0) ...
    Setting up metasploit (4.7.0-2013072401-1kali0) ...
    skipping metasploit initialization: postgres not running
    insserv: warning: current start runlevel(s) (empty) of script `metasploit' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `metasploit' overrides LSB defaults (0 1 6).
    Setting up set (5.1+0~git1375076559.2584c1-1) ...
    Setting up sqlmap (1.0+git20130217+0~git1374990203.b921ff-1) ...
    Setting up openjdk-6-jre-headless:amd64 (6b27-1.12.6-1~deb7u1) ...
    Installing new version of config file /etc/java-6-openjdk/security/java.security ...
    Setting up openjdk-6-jre-lib (6b27-1.12.6-1~deb7u1) ...
    Setting up openjdk-6-jre:amd64 (6b27-1.12.6-1~deb7u1) ...
    Setting up openjdk-6-jdk:amd64 (6b27-1.12.6-1~deb7u1) ...
    Setting up icedtea-6-jre-jamvm:amd64 (6b27-1.12.6-1~deb7u1) ...
    Setting up icedtea-6-jre-cacao:amd64 (6b27-1.12.6-1~deb7u1) ...
    root@Gr4nDT3R0R:~# apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@Gr4nDT3R0R:~# sqlmap
    Usage: python ./sqlmap [options]

    sqlmap: error: missing a mandatory option (-d, -u, -l, -m, -r, -g, -c, --wizard, --update, --purge-output or --dependencies), use -h for basic or -hh for advanced help
    [*] shutting down at 12:17:13

    root@Gr4nDT3R0R:~# sqlmap -u http://www.doors.com/vulnerable --dbs
    [1] 8478
    [2] 8479
    [3] 8480
    root@Gr4nDT3R0R:~#
    sqlmap/1.0-dev - automatic SQL injection and database takeover tool
    http://sqlmap.org

    [!] legal disclaimer: Usage of sqlmap for attacking targets without prior mutual consent is illegal. It is the end user's responsibility to obey all applicable local, state and federal laws. Developers assume no liability and are not responsible for any misuse or damage caused by this program
    [*] starting at 12:17:48

    [12:17:48] [INFO] testing connection to the target URL
    [12:17:55] [INFO] testing if the target URL is stable. This can take a couple of seconds
    [12:18:03] [WARNING] target URL is not stable. sqlmap will base the page comparison on a sequence matcher. If no dynamic nor injectable parameters are detected, or in case of junk results, refer to user's manual paragraph 'Page comparison' and provide a string or regular expression to match on
    how do you want to proceed? [(C)ontinue/(s)tring/(r)egex/(q)uit] y
    bash: y: command not found

    [1]+ Stopped sqlmap -u http://www.doors.com/page.cfm?storyset=yes
    [2] Done typeofsite=storydetail
    [3] Done ID=1167
    root@Gr4nDT3R0R:~#
    PLEASE HELP ME
    FACING THIS PROBLEME MORE THAN 3 TIMES
    Last edited by Gr4nD T3R0R; 2013-07-29 at 18:56. Reason: RESOLVED

  2. #2
    Join Date
    2014-Sep
    Posts
    4
    C not y
    that should do it

Similar Threads

  1. Replies: 1
    Last Post: 2015-10-20, 13:28
  2. Sqlmap command not found
    By azihak in forum General Archive
    Replies: 0
    Last Post: 2013-09-06, 07:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •