Results 1 to 5 of 5

Thread: Denied permission

  1. #1
    Join Date

    Denied permission


    I installed Kali last night on an acer aspire 5742z. I have been having different problems trying to get it to work. Firstly, I wasn't able to install it using the mirror as I also didn't configure the network as it wasn't able to detect my dchp server. I decided to install it without that stuff and do it after installation. So after I installed it I decided to populate my source.list repository. I found a link online ( ) and went with, this was as follows:

    vi /etc/apt/sources.list

    deb /kali main contrib non-free
    deb /wheezy main contrib non-free
    deb kali-dev main contrib non-free
    deb kali-dev main/debian-installer
    deb-src kali-dev main contrib non-free
    deb kali main contrib non-free
    deb kali main/debian-installer
    deb-src kali main contrib non-free
    deb kali/updates main contrib non-free
    deb-src kali/updates main contrib non-free




    Then I tried to do apt-get update and apt-get upgrade but it failed with a segmentation error. So I tried a few other things, not sure I remember everything, but now I am being denied permission to do a lot of stuff, for example I cannot get into /etc/apt/source.list. The reason I wanted to download these repositories was because I wanted to be able to download gedit and OfficeLibre, and wasn't able to. So I assumed that if I had all the packages I might be able to!

    I am also trying to start an apache server using the terminal and I script I downloaded into leafpad but it's returning that it unable to determine the servers qualified name. I'm wondering if there's something I need to do as I skipped configuring the network upon installation.

    Appreciate any and all help!!
    Thanks in advance!

  2. Hmmm. The segmentation error, may be the culprit. Sometimes this error happens when it tries to read or write to the memory that it shouldn't. (Though not sure as to why you got this error) And not knowing what steps you took after the fact, maybe you inadvertently made a mistake with something.

    You should be able to edit your sources.list file, especially if you are running as root. If you can't, I humbly recommend, just scrap it, and start over since you just started a fresh install. See if you can avoid the first trouble of the mirrors, try using a wired connection to start the install.
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  3. #3
    Join Date
    Try this:

    No. 1, keep sources.list as clean as possible, just in case. Please read here:
    Just 2 lines in sources.list

    Then, issue the command: --->aptitude clean

    After that, remove the .bin archives under /var/cahe/apt/: ----> rm -f /var/cache/apt/*.bin

    Try again apt-get update or aptitude update.

    I always use aptitude.

    Last edited by maverik35; 2013-11-07 at 03:23.

  4. #4
    Join Date
    Thanks For your replies. I went with your tips maverik35:

    Then, issue the command: --->aptitude clean

    After that, remove the .bin archives under /var/cahe/apt/: ----> rm -f /var/cache/apt/*.bin

    but the second returned with an error saying:

    rm: invalid option -- '/'

    I was trying to to run rm -rf/ and it returned the same the same error... weird! I think I'll go with your advice charonsecurity and wipe it and start over. Do I need to first delete this installation? And if so how do I go about doing that? Or will it the disk offer me the option to delete it?

    Thanks again,
    much appreciated.

  5. #5
    Try with putting your path between '

    rm -f '/var/cache/apt/*.bin'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts