Hi all,

I've been battling with the hash sum mismatch error for about a week.

Is everyone else currently updating from the repos fine?

I have tried the main kali repo and several of the archive errors and I still receive the same error.

I'm beginning to think it is not isolated as my downloads on windows have been corrupt several times now. That, and I am unable to download anything from steam as the download continues to reset with a very generic unable to download error.

I had a read on the internet and a few people pointed at RAM for this error. Unfortunately, 3 separate machines are showing the same symptoms, be it Windows or Linux.

I purchased a new modem / router today in the hopes that would fix it but it has not changed anything but the bank balance.

Does anyone have any ideas? I have removed all other phones devices, new ADSL filters, disconnected the monitored alarm system, reconnected the alarm system, made new cables, bought new cables, re-installed the operating system.

I'm just about out of ideas.