Hello everyone! New user here i am running Kali 1.0.9 iso on VMware player.
I have purchased a BELKIN N300 wireless network adapter to be able to use airmon-ng.
When i start the VM (kali) it automatically connects the the USB adapter.
wlan0     Link encap:Ethernet  HWaddr b4:75:0e:22:cd:f4  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
however when i run airmon-ng nothing shows up
root@KALI:~# airmon-ng

Interface	Chipset		Driver
root@KALI:~# lsusb
Bus 001 Device 002: ID 050d:845a Belkin Components F7D2101 802.11n Surf & Share Wireless Adapter v1000 [Realtek RTL8192SU]
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@KALI:~# iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     unassociated  Nickname:"rtl_wifi"
          Mode:Managed  Access Point: Not-Associated   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
My next thoughts were that i needed to find and install the driver for RTL8192SU
I went to http://www.realtek.com.tw/downloads/...Downloads=true to download the driver. I downloaded it and unzip the file. I have already installed the VMware tools and i used
sudo apt-get install build-essential linux-headers-generic
I then tried
root@KALI:~/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2. make
make: *** No targets specified and no makefile found.  Stop.
I then went deeper to the driver file and uncompressed the .tgz and then tried
root@KALI:~/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2. make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/3.12-kali1-amd64/build M=/root/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2.  modules
make: *** /lib/modules/3.12-kali1-amd64/build: No such file or directory.  Stop.
make: *** [modules] Error 2
At this point im lost I know that the Alfa works well with little issues from all sorts of post but i am trying to work through this for my own knowledge instead of giving up on it. If anyone can help or tell me that i am a retard and why it would be much appreciated.