Results 1 to 3 of 3

Thread: [Solved] Enable ssh at boot

  1. #1
    Join Date

    [Solved] Enable ssh at boot

    For a long time, I was unable to get the 'ssh' service to start up at boot time. I'll describe the problems I encountered, and then the solution. I used VMware Workstation v10.0.0.5 to create a 64 bit kali vm, installed from the latest (v1.1.0a) ISO.

    Out of the box, brand new, 'rcconf' does not even show/list the 'ssh' service.
    I could tweak the 'ssh' service with 'sysv-rc-conf', for run-levels 2, 3, 4 and 5. Reboot. 'rcconf' would then show the 'ssh' service.
    It still didn't start at boot (by checking service status, and ps). Another check in sysv-rc-conf would show ssh as still be started for run-levels 2, 3, 4, and 5.

    I looked into: "update-rc.d -f ssh enable 2 3 4 5" and that fixed the issue. The 'ssh' would be running after every reboot.

    Another interesting detail: The magic line at the top of /etc/init.d/ssh, contains a space: "#!<space>/bin/sh". I removed the space in my VM for consistency, but thought you all should know.


  2. #2
    Join Date
    Thank you Joe, I was having the same problem and your solution worked!


  3. #3
    Join Date
    Thanks Joe,

    The combination of sysv-rc-conf and update-rc.d did the trick. Had been struggling with this for a good part of yesterday trying the combination of update-rc.d -f ssh remove and update-rc.d -f ssh defaults (which should be the way to go according to a lot of articles I found on Google and that did indeed the trick with Kali 1). The blank in "#! /bin/sh" in /etc/init.d/ssh does not seem to have any eefect on it. But you're right, removing it is more consistent. I did your sysv-rc-conf trick, rebooted. Than did your update-rc.d trick and after a reboot service ssh status showed a very happy sshd running.

Similar Threads

  1. [SOLVED] Mingw-w64 on kali 4
    By johnp in forum How-To Archive
    Replies: 1
    Last Post: 2018-05-08, 04:26
  2. How to enable boot message log?
    By tr00n3r in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2015-10-27, 17:30
  3. Kali 2.0 enable boot log and all Kali tools are not found
    By deepak1501 in forum Installing Archive
    Replies: 0
    Last Post: 2015-10-03, 18:13
  4. Enable boot logging in Kali 2.0
    By UNIVAC in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-08-29, 07:56
  5. Replies: 7
    Last Post: 2014-08-10, 07:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts